Issue with Time Machine and com.apple.mimic_hfs

All your general support questions for OpenZFS on OS X.

Issue with Time Machine and com.apple.mimic_hfs

Postby stuart.c.holden » Thu Nov 07, 2019 3:01 pm

I have a zpool made up of two mirrored 4TB drives. There are three datasets on it and one ZVOL formatted as HFS+ for backing up my boot drive. The other pools are backed up to a cloud service.

I was having a problem with Time Machine, where it was reporting that it needed at least 2TB to do a backup, even though my boot drive is only 256GB. I suspected that it was trying to backup up my ZFS datasets as well, and after formatting an old 2TB drive as HFS+ and setting it up with Time Machine I confirmed this.

As I understand it, as per the FAQ, Time Machine excludes ZFS filesystems from backups by default. I tried going into the ZFS settings and clicking on the volumes to exlude them, but they were greyed out. I also tried setting exclusions from the command line but that also failed with an error.

After some googling I realized that years ago when I made the pools I set com.apple.mimic_hfs to 'on' as the FAQ recommends for HFS+ only applications. I tried that flag off for all of my volumes and the Time Machine backup automatically excluded my ZFS datasets as desired.

Which was great, until I ran Lightroom and it began behaving all wonky.

Lightroom is more important to me, so the easiest solution is to find another backup software or service and not use Time Machine.

Another solution is to replace the dataset I keep my photos on with a APFS formatted ZVOL. That seems a bit odd and clunky though.

The ideal solution is to make Time Machine properly exclude my datasets, but I'm stuck on that one.

Does anyone have any insight into this, or come across a similar problem? Is there anything really obvious that I'm missing?

Thank-you in advance,

Stu
stuart.c.holden
 
Posts: 1
Joined: Thu Nov 07, 2019 2:25 pm

Re: Issue with Time Machine and com.apple.mimic_hfs

Postby lundman » Thu Nov 07, 2019 4:47 pm

The mimic feature is just what ZFS reports, so you could certainly toggle it back on to use Lightroom - although that probably is a bit of a hassle. I wonder if timemachine has any dot-files to stop it from descending into directories.
User avatar
lundman
 
Posts: 647
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan


Return to General Help

Who is online

Users browsing this forum: No registered users and 9 guests