10.14 says 1.9.3 kexts are "incompatible"

All your general support questions for OpenZFS on OS X.

10.14 says 1.9.3 kexts are "incompatible"

Postby poolparty » Wed Oct 30, 2019 6:58 am

Just tried to update from OoO 1.9.0 to 1.9.3 on macOS 10.14.6.

It seems to have trouble loading the kexts. First, I uninstalled 1.9.0 successfully. Then I ran OoO’s Mojave installer for 1.9.3. It spawned two popups, each telling me a system extension has been blocked due to an incompatibility.
After that, I get:

Code: Select all
$ zpool version
Failed to load ZFS module stack.
Load the module manually by running '/sbin/kextload /Library/Extensions/zfs.kext' as root.
The /dev/zfs device is missing and must be created.
Try running 'udevadm trigger' as root to create it.


Code: Select all
$ sudo kextutil /Library/Extensions/spl.kext 2>&1 | tail
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.33 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.33.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.33 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.33 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.33.
Diagnostics for /Library/Extensions/spl.kext:
Dependency Resolution Failures:
    Only incompatible kexts found for these libraries:
        net.lundman.kernel.dependencies.33


A reboot won’t help.
What do I need to resolve this?
User avatar
poolparty
 
Posts: 12
Joined: Mon Apr 30, 2018 11:34 am

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby poolparty » Wed Oct 30, 2019 7:13 am

Two additional bits of info:

  • Uninstalling, then re-installing 1.9.3 won’t help. The installer will no longer cause the popups to appear but the kexts still won’t load, and running kextutil still gives me the same error messages.
  • Uninstalling, then going back to 1.9.2 (the 2019-08-01 release) works just fine.
User avatar
poolparty
 
Posts: 12
Joined: Mon Apr 30, 2018 11:34 am

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby lundman » Wed Oct 30, 2019 9:37 pm

And there is no "Allow" button in Apple Logo > System Preferences > click 'Security and Privacy' ?

I just reinstalled 1.9.3 on the 10.14/Mojave VM without issues, so it is curious why your system has decided to reject "net.lundman.kernel.dependencies.33"
User avatar
lundman
 
Posts: 647
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby lundman » Wed Oct 30, 2019 9:44 pm

Hmm You might have to uninstall, reboot, then install.
User avatar
lundman
 
Posts: 647
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby FadingIntoBlue » Wed Oct 30, 2019 9:51 pm

Just tried to install myself, got The Installer failed error. Install log as follows:

Code: Select all
================================================================================
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: It took 0.00 seconds to summarize the package selections.
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: location = file://localhost
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: file://localhost/Volumes/OpenZFS%20on%20OS%20X%201.9.3/OpenZFS%20on%20OS%20X%201.9.3%20Mojave.pkg#zfs1014.pkg
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: Set authorization level to root for session
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: Will use PK session
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: Using authorization level of root for IFPKInstallElement
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: Starting installation:
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: Configuring volume "Mini18-SSD"
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: Preparing disk for local booted install.
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: Free space on "Mini18-SSD": 167.6 GB (167600967680 bytes).
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: Create temporary directory "/var/folders/p7/87dg154543gcc8klhfz38wsc0000gr/T//Install.12681F9eON"
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: IFPKInstallElement (1 packages)
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: Adding client PKInstallDaemonClient pid=1268, uid=504 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
2019-10-31 16:42:02+11 mini18-kiwiephemera-com Installer[1268]: PackageKit: Enqueuing install with framework-specified quality of service (utility)
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: ----- Begin install -----
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: request=PKInstallRequest <1 packages, destination=/>
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: packages=(
       "PKLeopardPackage <id=net.lundman.openzfs.1014.pkg, version=17.0, url=file:///Volumes/OpenZFS%20on%20OS%20X%201.9.3/OpenZFS%20on%20OS%20X%201.9.3%20Mojave.pkg#zfs1014.pkg>"
   )
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: Set reponsibility for install to 1268
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: Will do receipt-based obsoleting for package identifier net.lundman.openzfs.1014.pkg (prefix path=)
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: Extracting file:///Volumes/OpenZFS%20on%20OS%20X%201.9.3/OpenZFS%20on%20OS%20X%201.9.3%20Mojave.pkg#zfs1014.pkg (destination=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/FE3806B3-18A3-4038-8B5E-8A156D6499DC.activeSandbox/Root, uid=0)
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: Moving directory /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/FE3806B3-18A3-4038-8B5E-8A156D6499DC.activeSandbox/Root/etc to /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/FE3806B3-18A3-4038-8B5E-8A156D6499DC.activeSandbox/Root/private/etc in sandbox to account for symlink
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: prevent user idle system sleep
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: suspending backupd
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: PackageKit: Executing script "./preinstall" in /private/tmp/PKInstallSandbox.dP16P2/Scripts/net.lundman.openzfs.1014.pkg.jO6fM1
2019-10-31 16:42:02+11 mini18-kiwiephemera-com install_monitor[1296]: Temporarily excluding: /Applications, /Library, /System, /bin, /private, /sbin, /usr
2019-10-31 16:42:02+11 mini18-kiwiephemera-com _reportmemoryexception[1299]: Running Install Scripts . . .
2019-10-31 16:42:02+11 mini18-kiwiephemera-com _reportmemoryexception[1301]: Begin script: 0uninstall
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/MacOS: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/PlugIns: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/_CodeSignature: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/Resources: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/Resources/English.lproj: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/_CodeSignature: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents/MacOS: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents/Resources: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents/Resources/English.lproj: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents/_CodeSignature: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems/zfs.fs: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems/zfs.fs/Contents: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems/zfs.fs/Contents/Resources: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems/zfs.fs/Contents/Resources/English.lproj: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/LaunchDaemons: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /etc: Not a directory
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /etc/zfs: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /etc/zfs/zed.d: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/bin: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/lib: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/libexec: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/libexec/zfs: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/libexec/zfs/launchd.d: Directory not empty
2019-10-31 16:42:02+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/libexec/zfs/zed.d: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/man: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/man/man1: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/man/man5: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/man/man8: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/zfs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/zfs/zpios-profile: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/zfs/zpios-test: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/zfs/zpool-config: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/PlugIns: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents/Resources: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/spl.kext/Contents: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents/Resources: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions/zfs.kext/Contents: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Extensions: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems/zfs.fs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems/zfs.fs/Contents: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems/zfs.fs/Contents/Resources: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/Filesystems: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /Library/LaunchDaemons: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /etc: Not a directory
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /etc/zfs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /etc/zfs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/libexec: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/libexec/zfs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/libexec/zfs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/man: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/man: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/man: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/man: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/zfs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/zfs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share/zfs: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: rmdir: /usr/local/share: Directory not empty
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Forgot package 'net.lundman.openzfs.1014.pkg' on '/'.
2019-10-31 16:42:03+11 mini18-kiwiephemera-com _reportmemoryexception[1768]: End script: 0uninstall
2019-10-31 16:42:03+11 mini18-kiwiephemera-com _reportmemoryexception[1769]: Begin script: lookforzpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for /dev/zfs
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Found /dev/zfs
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at /Library/OpenZFSonOSX/ZFSUserland/usr/local/sbin/zpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at /Library/OpenZFSonOSX/ZFSCommandLineTools/usr/sbin/zpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at /usr/sbin/zpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at /usr/local/sbin/zpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at /sbin
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at /usr/local/bin/zpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at /usr/bin/zpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at /bin/zpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Checking for zpool command at zpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com _reportmemoryexception[1773]: End script: lookforzpool
2019-10-31 16:42:03+11 mini18-kiwiephemera-com _reportmemoryexception[1774]: Begin script: unloadzfs
2019-10-31 16:42:03+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Unloading zfs.kext
2019-10-31 16:42:10+11 mini18-kiwiephemera-com installd[894]: ./preinstall: (kernel) Can't unload kext net.lundman.zfs; classes have instances:
2019-10-31 16:42:10+11 mini18-kiwiephemera-com installd[894]: ./preinstall: (kernel)     Kext net.lundman.zfs class ZFSDataset has 1 instance.
2019-10-31 16:42:10+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Failed to unload net.lundman.zfs - (libkern/kext) kext is in use or retained (cannot unload).
2019-10-31 16:42:10+11 mini18-kiwiephemera-com installd[894]: ./preinstall: Died at /tmp/PKInstallSandbox.dP16P2/Scripts/net.lundman.openzfs.1014.pkg.jO6fM1/preinstall line 43.
2019-10-31 16:42:10+11 mini18-kiwiephemera-com install_monitor[1296]: Re-included: /Applications, /Library, /System, /bin, /private, /sbin, /usr
2019-10-31 16:42:11+11 mini18-kiwiephemera-com installd[894]: PackageKit: releasing backupd
2019-10-31 16:42:11+11 mini18-kiwiephemera-com installd[894]: PackageKit: allow user idle system sleep
2019-10-31 16:42:11+11 mini18-kiwiephemera-com installd[894]: PackageKit: Cleared permissions on Installer.app
2019-10-31 16:42:11+11 mini18-kiwiephemera-com installd[894]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “OpenZFS on OS X 1.9.3 Mojave.pkg”." UserInfo={NSFilePath=./preinstall, NSURL=file:///Volumes/OpenZFS%20on%20OS%20X%201.9.3/OpenZFS%20on%20OS%20X%201.9.3%20Mojave.pkg#zfs1014.pkg, PKInstallPackageIdentifier=net.lundman.openzfs.1014.pkg, NSLocalizedDescription=An error occurred while running scripts from the package “OpenZFS on OS X 1.9.3 Mojave.pkg”.} {
       NSFilePath = "./preinstall";
       NSLocalizedDescription = "An error occurred while running scripts from the package \U201cOpenZFS on OS X 1.9.3 Mojave.pkg\U201d.";
       NSURL = "file:///Volumes/OpenZFS%20on%20OS%20X%201.9.3/OpenZFS%20on%20OS%20X%201.9.3%20Mojave.pkg#zfs1014.pkg";
       PKInstallPackageIdentifier = "net.lundman.openzfs.1014.pkg";
   }
2019-10-31 16:42:11+11 mini18-kiwiephemera-com installd[894]: PackageKit: Running idle tasks
2019-10-31 16:42:11+11 mini18-kiwiephemera-com Installer[1268]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “OpenZFS on OS X 1.9.3 Mojave.pkg”." UserInfo={NSFilePath=./preinstall, NSURL=file:///Volumes/OpenZFS%20on%20OS%20X%201.9.3/OpenZFS%20on%20OS%20X%201.9.3%20Mojave.pkg#zfs1014.pkg, PKInstallPackageIdentifier=net.lundman.openzfs.1014.pkg, NSLocalizedDescription=An error occurred while running scripts from the package “OpenZFS on OS X 1.9.3 Mojave.pkg”.}
2019-10-31 16:42:11+11 mini18-kiwiephemera-com installd[894]: PackageKit: Removing client PKInstallDaemonClient pid=1268, uid=504 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
2019-10-31 16:42:11+11 mini18-kiwiephemera-com installd[894]: PackageKit: Done with sandbox removals
2019-10-31 16:42:11+11 mini18-kiwiephemera-com Installer[1268]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
2019-10-31 16:42:11+11 mini18-kiwiephemera-com Installer[1268]: IFDInstallController 187D260 state = 8
2019-10-31 16:42:11+11 mini18-kiwiephemera-com Installer[1268]: Displaying 'Install Failed' UI.
2019-10-31 16:42:11+11 mini18-kiwiephemera-com Installer[1268]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.
2019-10-31 16:42:15+11 mini18-kiwiephemera-com Installer[1268]: Package Removal: Package is not in downloads directory. Not offering removal.
2019-10-31 16:42:15+11 mini18-kiwiephemera-com Installer[1268]: Package Removal: Package cannot be removed.
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: @(#)PROGRAM:Install  PROJECT:Install-1000
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: @(#)PROGRAM:Installer  PROJECT:Installer-934.2
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Hardware: Macmini8,1 @ 3.20 GHz (x 12), 65536 MB RAM
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Running OS Build: Mac OS X 10.14.6 (18G1012)
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: __CF_USER_TEXT_ENCODING=0x1F8:0:15
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: TMPDIR=/var/folders/p7/87dg154543gcc8klhfz38wsc0000gr/T/
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: HOME=/Users/hmedia
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: SHELL=/bin/bash
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: Apple_PubSub_Socket_Render=/private/tmp/com.apple.launchd.qYtWJmQxh7/Render
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.IbGMSm4rRB/Listeners
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: LOGNAME=hmedia
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: XPC_SERVICE_NAME=com.apple.xpc.launchd.oneshot.0x10000004.Installer
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: COMMAND_MODE=unix2003
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: USER=hmedia
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Env: XPC_FLAGS=0x0
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: OpenZFS on OS X 1.9.3 Installation Log
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Opened from: /Volumes/OpenZFS on OS X 1.9.3/OpenZFS on OS X 1.9.3 Mojave.pkg
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Package Authoring Error: <background> has an unsupported MIME type: image/data
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Package Authoring Error: <background-darkAqua> has an unsupported MIME type: image/data
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Package Authoring Error: <background_scaling> has an unsupported MIME type: X-NSObject/NSNumber
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Package Authoring Error: <background_alignment> has an unsupported MIME type: X-NSObject/NSNumber
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Package Authoring Error: <layout-direction> has an unsupported MIME type: X-NSObject/NSNumber
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: Product archive /Volumes/OpenZFS on OS X 1.9.3/OpenZFS on OS X 1.9.3 Mojave.pkg trustLevel=202
2019-10-31 16:42:48+11 mini18-kiwiephemera-com Installer[1788]: External component packages (1) trustLevel=202


Hope that helps
FadingIntoBlue
 
Posts: 39
Joined: Tue May 27, 2014 12:25 am

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby FadingIntoBlue » Wed Oct 30, 2019 10:36 pm

Just tried to install myself, got The Installer failed error.


A restart and running the installer again sorted it :)

No "incompatible" messages, Mojave installer, Mojave 10.14.6, lastest security update installed today.
FadingIntoBlue
 
Posts: 39
Joined: Tue May 27, 2014 12:25 am

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby lundman » Wed Oct 30, 2019 11:02 pm

This might be an issue with going from 1.9.2 -> 1.9.3. Looks like the kext have the same version, so a clean uninstall, reboot, install; is needed.
User avatar
lundman
 
Posts: 647
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby Marco » Thu Oct 31, 2019 2:49 am

I have the same exact problem.
AboutMyMac Software/Extensions says that zfs.kext version 1.9.3 is not loaded.
I used uninstall-openzfsonosx.sh to unistall, then rebooted, the installed again using 1.9.3 for Mojave.
This time there was no incompatible extension error dialogue, but AboutMyMac still says that zfs.kext version 1.9.3 is not loaded. There was no dialogue to grant permission to zfs.kext to load, either.
I uninstalled again, then installed again using 1.9.2 for Mojave, and it works. Now AboutMyMac Software/Extensions says that zfs.kext version 1.9.2 is loaded.
Marco
 
Posts: 32
Joined: Tue Mar 25, 2014 1:39 am

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby poolparty » Thu Oct 31, 2019 9:39 am

lundman wrote:And there is no "Allow" button in Apple Logo > System Preferences > click 'Security and Privacy' ?

I just reinstalled 1.9.3 on the 10.14/Mojave VM without issues, so it is curious why your system has decided to reject "net.lundman.kernel.dependencies.33"


I don’t see an "Allow" button in the Security and Privacy pane. I’ve uninstalled, rebooted, and reinstalled 1.9.2 and 1.9.3 several times.
The results are consistent: 1.9.2 works, 1.9.3 doesn’t.

However, I just noticed the following line in my system log stream after trying to load the kexts via kextutil:

Code: Select all
[…] syspolicyd: (Security) [com.apple.securityd:security_exception] MacOS error: 3
[…] syspolicyd: (Security) [com.apple.securityd:SecError] Error checking with notarization daemon: 3
[…] syspolicyd: Non-notarized kext blocked: <private>, Fri Oct 25 10:41:14 2019


The timestamp given matches the last modification date of the CodeResources file inside all three kexts by a margin of 1 second.
Did you notarize all the kexts, including the nested one?
User avatar
poolparty
 
Posts: 12
Joined: Mon Apr 30, 2018 11:34 am

Re: 10.14 says 1.9.3 kexts are "incompatible"

Postby Marco » Fri Nov 01, 2019 2:18 am

Before upgrading to Catalina, I was waiting for the 10.15.1 update and for OpenZFS to be stable. Since 1.9.3 has problems on Mojave, I decided to move to Catalina. I did, and I succesfully installed 1.9.3. As expected, the system asked for authorization to load zfs.kext, so I granted it. I no longer personally need help for 1.9.3 on Mojave, but I can witness that Mojave didn't ask for authorization to load zfs.kext and that I was unable to have it load.
Marco
 
Posts: 32
Joined: Tue Mar 25, 2014 1:39 am

Next

Return to General Help

Who is online

Users browsing this forum: No registered users and 11 guests