Catalina support

All your general support questions for OpenZFS on OS X.

Catalina support

Postby aligature » Mon Oct 07, 2019 3:33 pm

Does anyone know if the 1.9.2 release explicitly supports MacOS Catalina?
aligature
 
Posts: 8
Joined: Mon Oct 16, 2017 6:07 pm

Re: Catalina support

Postby lundman » Mon Oct 07, 2019 3:44 pm

I posted a .pkg for Catalina yesterday.
User avatar
lundman
 
Posts: 709
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Catalina support

Postby aligature » Mon Oct 07, 2019 5:34 pm

Oh, I do see that now. Sorry, I didn’t see any mention in the release notes so I wasn’t sure. Thanks!
aligature
 
Posts: 8
Joined: Mon Oct 16, 2017 6:07 pm

Re: Catalina support

Postby pnerd » Tue Oct 08, 2019 12:04 am

Howdy. I'm getting errors with this new pkg on my freshly upgraded MacPro 2013 Catalina system. I then installed the previously released stable 1.9.2 and was able to mount my pool and read/write to it. Unmounting and remounting failed and open reboot, got the same type of error. Anyone see the same? Hints?

$ sudo zpool import -a
libzfs_import.c:371: pool_active: Assertion `nvlist_lookup_uint64(zhp->zpool_config, ZPOOL_CONFIG_POOL_GUID, &theguid) == 0` failed.
Abort trap: 6
pnerd
 
Posts: 2
Joined: Mon Oct 07, 2019 11:59 pm

Re: Catalina support

Postby lundman » Tue Oct 08, 2019 3:54 pm

Catalina appears to hold on to kexts beyond what we expect, we have found instances where users reboot, it would load old kexts.

You can check loaded versions with:
Code: Select all
$ zpool version
zfs-1.9.2-4-g4889d276e0
zfs-kmod-1.9.2-4-g4889d276e0

$ sysctl spl.kext_version zfs.kext_version
spl.kext_version: 1.9.2-2-ge1134e33
zfs.kext_version: 1.9.2-4-g4889d276e0


The zpool import error you get is usually caused by mismatched userland(zpool) version and kext version.
User avatar
lundman
 
Posts: 709
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Catalina support

Postby cgiard » Sun Oct 20, 2019 7:21 am

cgiard
 
Posts: 4
Joined: Sat Dec 20, 2014 8:10 am

Re: Catalina support

Postby lundman » Sun Oct 20, 2019 4:10 pm

Ah yes, that is it exactly - at least it isn't just us.
User avatar
lundman
 
Posts: 709
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Catalina support

Postby pnerd » Thu Oct 24, 2019 5:24 pm

Thank you all for shedding light on the issue. I was able to work around the Catalina kext bug by using the uninstall script, manually deleting the spl.kext and zfs.kext files in /Library/Extensions/ rebooting and then installing the Catalina Supplemental Update which fortuitously became available during my time debugging this. I installed ZFS after the update and I was able to verify I had the right kext versions after that.

I see there's a new ZFS build and if I understand the linked analysis, there's not an easy workaround. Does anyone know if this is addressed in the upcoming Catalina 10.15.1 update? The third developer beta was released today.
pnerd
 
Posts: 2
Joined: Mon Oct 07, 2019 11:59 pm


Return to General Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron