finder naming overlay issue received filesystem from linux

All your general support questions for OpenZFS on OS X.

finder naming overlay issue received filesystem from linux

Postby gregthegeek » Thu Mar 28, 2019 7:16 pm

For fun I'm playing with a shared pool between Linux and Mac where I would like to zfs send a Linux Postgresql db to the Mac zfs disk. I ran this over the network from linux, and with USB, but the pool resides on Mac. I'd love to get incremental snapshots sent,but I can't even browse the initial send data. What I'm seeing is the fs name overlayed on top of the folder names on Mac. It might show for a split second in Finder but then swap immediately to the fs name and no file show below.

Here's an example. I've sent from linux native zfs pool to a usb attached mac pool:
source: netp1/DATA/data-1/pgsql@ready-move-brinstar-0
dest (mac pool) : boyon/psql

Sending worked normally...
exported, attached to mac, import...
I set a mountpoint in boyon/psql to /Volumes/psql
in terminal listing the mount works, after setting perms. I can see all the way into the postgres data.
/Volumes/psql/10/data ... (mount different, but same structure on linux, as expected)

In finder: I see this in /Volumes:
psql
> psql
> psql
> psql

And each one of those has the zfs icon like its a disk.

I just looked and this is also an issue on viewing files under any Linux created structure, even after setting perm/owners.

I'm running 1.8.2 and Majave. Just checked on a High Sierra system, but it has 1.8.2 now, and doing same thing. If it helps, I can try downgrading the HS system? I don't remember this being an issue before. I could swear I was able to pull data off the disk from either source that created it. Normally I have separate sections/filesytems on the pool for each system. In this case though, I'm trying to sync the data so mac can use it.
gregthegeek
 
Posts: 8
Joined: Wed Dec 23, 2015 6:25 pm

Re: finder naming overlay issue received filesystem from lin

Postby Sharko » Mon Apr 01, 2019 11:34 am

Do you have com.apple.mimic_hfs=on set on the Mac pool (boyon/psql)? Other than that, I'm thinking that some feature or features on the linux-generated pool aren't supported on the Mac yet. What version of zfs is in play on the linux side?

I guess another thing you could try would be to do a zfs send on the linux side, with a zfs receive (and store to external disk) on the Mac side, through ssh.
Sharko
 
Posts: 79
Joined: Thu May 12, 2016 12:19 pm

Re: finder naming overlay issue received filesystem from lin

Postby lundman » Mon Apr 01, 2019 3:44 pm

Do they all end with the same name? path1/pqsl, path2/pqsl ? Finder does not like that
User avatar
lundman
 
Posts: 530
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: finder naming overlay issue received filesystem from lin

Postby gregthegeek » Tue Apr 02, 2019 12:25 pm

Yeah, I have ZoL 0.7.13, but it was a pool created on Mac with 1.8.2, then opened on LInux to copy files, then brought back to Mac.

The folder names are all correct on linux, and on terminal in Mac, no duplicate names. Its when they open on Mac again Finder is showing only that dataset name on each of the subfolders.

Also, com.apple.mimic_hfs=on is set.

I'll do some individual tests later with dedicated disks and report back.
gregthegeek
 
Posts: 8
Joined: Wed Dec 23, 2015 6:25 pm

Re: finder naming overlay issue received filesystem from lin

Postby gregthegeek » Sat Apr 06, 2019 7:19 pm

Update on tests. I created a new pool on Mac. Setup datasets with com.apple properties. Then took to linux and created a new dataset for linux called FuneLinuxData without any com.apple properties (can't anyway, invalid on LInux), then added files and folders. I also added files and folders to the Mac specific datasets from Linux.

After taking back to Mac, the files and folders in Finder are ok in the Mac datasets. However, it was the dataset created for LInux that had the folder renaming. I attached a screenshot. In that there should be a file called F21.png, but instead shows the ZFS disk icon and name FuneLinuxData. Also, this happens on 1.7.4 on Mojave too.

This isn't really a big problem for me. I don't normally transfer my disks like this. I'm just trying to note the weirdness. I can get by without using zfs linux data, will just have to rsync where needed instead of send/recv.
Attachments
fune-linux-finder-issue.jpg
finder issue
fune-linux-finder-issue.jpg (64.82 KiB) Viewed 109 times
gregthegeek
 
Posts: 8
Joined: Wed Dec 23, 2015 6:25 pm


Return to General Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron