Duplicate inode on Sierra 10.12.6 with OpenZFS on OS X 1.6.2

We won't tell.

Duplicate inode on Sierra 10.12.6 with OpenZFS on OS X 1.6.2

Postby by4konata » Fri Sep 07, 2018 1:57 am

Hi, All,

This weird thing happens:

From terminal I am able to enter my directories properly:

Code: Select all
[root@frideracs ~]# zfs get mountpoint
NAME  PROPERTY    VALUE          SOURCE
DATA  mountpoint  /Volumes/DATA  default
[root@frideracs ~]# cd /Volumes/DATA
[root@frideracs DATA]# cd TV_Series
[root@frideracs TV_Series]# pwd
/Volumes/DATA/TV_Series
[root@frideracs TV_Series]# ls -l |head -5
total 343
-rw-r--r--   1 bzh  staff  6148 Apr 29  2014 .DS_Store
drwxrwxrwx  13 bzh  staff    13 Feb 18  2018 Agatha Christie's Poirot
drwxrwxrwx   4 bzh  staff     4 Mar 25 21:47 American Crime Story
drwxrwxrwx   3 bzh  staff     3 May 24  2017 American Gods
[root@frideracs TV_Series]#


However when I try to enter the same directory from finder it keeps entering DATA so looping in the same dir as if it is symlink (which it is not)
Image

At some point I checked the inodes and it appears that the inode for TV_series is the same as the inode for the pool mountpoint folder:
Code: Select all
[root@frideracs TV_Series]# ls -li /Volumes/
total 57
      2 drwxr-xr-x@ 24 bzh   wheel  24 Sep  7 12:50 DATA
1888462 lrwxr-xr-x   1 root  wheel   1 Sep  7 10:54 OSX -> /
[root@frideracs TV_Series]# ls -li /Volumes/DATA/
total 1046
163842 drwx------    5 root  wheel       5 Aug 26 12:15 .Spotlight-V100
  5451 d-wx-wx-wt    3 root  wheel       3 Aug 29 13:41 .TemporaryItems
163854 d-wx-wx-wt    3 root  wheel       3 Sep  7 11:59 .Trashes
163841 -rw-r--r--    1 root  wheel  239735 Aug 26 12:15 .VolumeIcon.icns
196609 drwx------   69 root  wheel      69 Sep  7 12:36 .fseventsd
   917 drwxr-xr-x    4 bzh   staff       4 Apr 17 21:04 Archive
/.../
     2 drwxr-xr-x   25 bzh   staff      25 Sep  7 12:01 TV_Series
196660 drwxr-xr-x   10 bzh   staff      10 Aug 27 09:37 Tutorials
   927 drwxr-xr-x    4 bzh   staff       4 Jun  9 14:22 VMs
   928 drwxr-xr-x    8 bzh   staff       8 Jul  7  2016 Video_Clips
[root@frideracs TV_Series]#


Oddly enough when working from terminal that is not an issue...

WUT?
Any ideas?
by4konata
 
Posts: 1
Joined: Fri Sep 07, 2018 1:44 am

Return to Hackintoshes

Who is online

Users browsing this forum: No registered users and 0 guests

cron