Disks show as REMOVED

All your general support questions for OpenZFS on OS X.

Disks show as REMOVED

Postby mkush » Wed May 02, 2018 6:32 am

I was happily filling up my new pool last night (specs below). I left the computer for a while and came back. I was going to export the pool so I could take the computer with me. Prior to doing so, I just wanted to take a peek at the data I had just copied. When I went to open the folder in Finder, there were no files shown. Oddly, in Terminal, I could see the files. After several minutes of waiting, I decided to export the pool anyway. It would not export. Then I did a zpool status, which showed two of the SSDs as REMOVED and a pool status of "One or more devices are faulted in response to IO failures." The pool showed as UNAVAIL due to "insufficient replicas". Read and write errors were reported for the pool, but not the individual disks. Disk Utility showed only two of the four disks. Unable to export I tried to shut the computer down. It refused. I then forcibly powered it off. Upon rebooting (and possibly importing, can't remember), there was my pool, just fine, no read, write or data errors showing.

So, my questions:

1. Should I be scared for the integrity of my data, or if the pool reports itself as fine, just trust that it is fine?
2. What would cause this? My only theory is that "Put hard disks to sleep when possible" was turned on in Energy Saver. Could that be the issue? I have now turned it off.

Pool is made of 4x Samsung 850 EVO 4TB drives in RAIDZ1 mounted in an Akitio Thunder3 Quad Mini enclosure, connected to a 2017 MacBook Pro 15". This is the same setup I've written about in the other thread I started regarding long pauses during write, solved by setting ARC to 1GB. Running 1.7.2.
Posts: 27
Joined: Tue Sep 30, 2014 1:17 pm

Re: Disks show as REMOVED

Postby lundman » Sun May 06, 2018 3:55 pm

The disks slipped offline, which is odd - but generally something on the OS side, we just use the disks that OsX presents to us. Now if they renumbered, due to USB, using the invariantpaths will help.
User avatar
Posts: 370
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Return to General Help

Who is online

Users browsing this forum: No registered users and 1 guest