2.1.99 test feedback

Developer discussions.

2.1.99 test feedback

Postby melliott » Tue Feb 15, 2022 9:16 am

Installed on a MacPro running MacOSX 10.15.7 with 2.1 installed. At the end of the installer the system paniced. Booted back up and had loaded the new versions of OpenAFS on OS X. Pool import worked fine and I've been copying data to my pool for the last hour without any issues.
melliott
 
Posts: 3
Joined: Wed Apr 23, 2014 6:16 am

Re: 2.1.99 test feedback

Postby FadingIntoBlue » Fri Feb 18, 2022 1:26 pm

Installed on a MacMini running Monterey 12.2.1 2018, 64GB
Install went completely smoothly and as expected
Import was over the top of 2.1.0, I did not remove any elements of that.

Code: Select all
sysctl -a | grep kext
debug.kextlog: 4083
zfs.kext_version: 2.1.99-752_g1abfb1ddd

Imported pool used on my M1 iMac, using -f flag, non encrypted filesystems as expected
Key load for encrypted filesystems as expected, same mounted without difficulty
Pool and all mounted filesystems exported as expected, did not need -f flag

Pool remounted as expected on M1 iMac, without requiring -f flag

Which brings me to my question, is 2.1.99 Intel only or will it install on an M1 Mac? Happy to test if you are not sure, but I imagine you are :)

Many thanks for the work to bring this new version near completion, it is looking good so far. Will give a further tryout on a non-prodcution pool as time permits
FadingIntoBlue
 
Posts: 93
Joined: Tue May 27, 2014 12:25 am

Re: 2.1.99 test feedback

Postby FadingIntoBlue » Sun Feb 20, 2022 6:27 pm

I said:
Which brings me to my question, is 2.1.99 Intel only or will it install on an M1 Mac?


Well, answered that one for myself :lol:

Code: Select all
% sudo /sbin/kextload /Library/Extensions/zfs.kext
Executing: /usr/bin/kmutil load -p /Library/Extensions/zfs.kext
Error Domain=KMErrorDomain Code=71 "Incompatible architecture: Binary is for x86_64, but needed arch arm64e
Unsupported Error: one or more extensions are unsupported to load    Kext org.openzfsonosx.zfs v2.1.99 in executable kext bundle org.openzfsonosx.zfs at /Library/Extensions/zfs.kext
FadingIntoBlue
 
Posts: 93
Joined: Tue May 27, 2014 12:25 am

Re: 2.1.99 test feedback

Postby lundman » Sun Feb 20, 2022 8:26 pm

Yes intel only for now, I'll build an arm if there are nothing major to fix..
User avatar
lundman
 
Posts: 1160
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: 2.1.99 test feedback

Postby lundman » Mon Feb 21, 2022 2:16 am

Ah just realised the code that checks for "too deep stack" is not in this branch, so scrubs could panic. I'll have that fixed up.
User avatar
lundman
 
Posts: 1160
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: 2.1.99 test feedback

Postby melliott » Mon Feb 21, 2022 10:12 am

I upgraded my Mac Pro running Mac OS 10.15.7 to Mac OS 12.2.1. System booted back up without panic and is running fine with the previously installed OpenZFSonMacOSX 2.1.99.
melliott
 
Posts: 3
Joined: Wed Apr 23, 2014 6:16 am

Re: 2.1.99 test feedback

Postby dmz » Wed Jul 20, 2022 2:29 pm

Is there an arm64 build available for 2.1.99 at this point? (I'm about to migrate from an Intel to an Apple Silicon machine, and would like to make sure I can run OpenZFS on 12.4 or 12.5...)
dmz
 
Posts: 18
Joined: Thu Mar 13, 2014 10:03 pm

Re: 2.1.99 test feedback

Postby colindean » Mon Sep 05, 2022 12:50 pm

Latest build seems very solid! Installed successfully on MacBookAir ("Early 2015") and iMac ("2017"), both running Monterey 12.5.1. Previous build just hung at setting up preboot, but latest works fine.

Each Mac has single pool on external Seagate ST2000LM015 2TB HDD in a USB 3 enclosure. Each successfully created pool and populated with 6 datasets (total 414 snapshots) to ~ 40% of disk capacity by zfs send/receive over 1Gbit/s Ethernet from master pool on Dell PowerEdge T320 running Debian 11.4 (took ~ 9hrs 45mins each - not both at once).

Prior to this, the last viable installations we had were on High Sierra - we never got anything to run without frequent crashes on Mojave, Catalina or Big Sur.

Very pleased to have this working again! Thanks for all your hard work.
colindean
 
Posts: 3
Joined: Wed Apr 11, 2018 2:46 am
Location: Durham, UK

Re: 2.1.99 test feedback

Postby FadingIntoBlue » Fri Sep 09, 2022 2:59 pm

Installed on MacBook Air M1 2020 with no difficulty, upgrading over 2.1.0-1, public beta 2 of 13.0 Ventura

Imported, export and mounted an encrypted pool with no problems also. Mounted encrypted filesystem also. Read and write also working.
Exported same without problems, including mounted filesystems, no force required.

Looking very good to me!

Many thanks again for your hard work and dedication.
FadingIntoBlue
 
Posts: 93
Joined: Tue May 27, 2014 12:25 am

Re: 2.1.99 test feedback

Postby Jaw3000 » Wed Sep 28, 2022 1:06 pm

I'm confused about builds. The latest releases on Github are for Big Sur, Mavericks, El Capitan, and Catalina. The latest builds in the announcements section of this forum are for Catalina and Monterey/Arm64. The version numbers on Github for Big Sur (latest OS mentioned) are older than the version numbers for Catalina and El Capitan builds. Most of these builds are for quite old OS versions now. I don't see anything for Monterey/Intel? Is there a problem getting ZFS to work on Monterey/Intel? What about upcoming Ventura?

Thanks for all of the hard work on getting this to work. I've been using builds for years now, and they have been remarkably stable for my use. I really appreciate it!
Jaw3000
 
Posts: 4
Joined: Thu May 06, 2021 11:15 pm


Return to OpenZFS on OS X Development

Who is online

Users browsing this forum: No registered users and 1 guest