Emojis appear to make the forum go boom. :(

Issues regarding the forums and O3XWiki.

Emojis appear to make the forum go boom. :(

Postby Wowfunhappy » Wed Jun 02, 2021 3:05 pm

I attempted to post a message which contained the "thinking face" emoji, which resulted in this lovely bit of loveliness:

Screen Shot 2021-06-02 at 7.00.59 PM.png
Screen Shot 2021-06-02 at 7.00.59 PM.png (77.59 KiB) Viewed 118 times


This prompted me to try a few other emojis too, with similar results. Not exactly a big deal, but I thought I'd leave a note!
Wowfunhappy
 
Posts: 32
Joined: Sat Jul 21, 2018 11:58 am

Re: Emojis appear to make the forum go boom. :(

Postby nodarkthings » Thu Jun 03, 2021 1:02 am

:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
From here, it looks ok.
nodarkthings
 
Posts: 143
Joined: Mon Jan 26, 2015 10:32 am

Re: Emojis appear to make the forum go boom. :(

Postby Wowfunhappy » Thu Jun 03, 2021 2:22 am

Those aren't emoji. Those are emoticons.

These are emoji, try copy pasting them! https://itty.bitty.site/#Emojis/?XQAAAA ... //glwAAA==
Last edited by Wowfunhappy on Thu Jun 03, 2021 2:27 am, edited 1 time in total.
Wowfunhappy
 
Posts: 32
Joined: Sat Jul 21, 2018 11:58 am

Re: Emojis appear to make the forum go boom. :(

Postby nodarkthings » Thu Jun 03, 2021 2:26 am

Ah, ok. :lol: Well, I suppose the forum simply doesn't support that. ;)
nodarkthings
 
Posts: 143
Joined: Mon Jan 26, 2015 10:32 am

Re: Emojis appear to make the forum go boom. :(

Postby lundman » Wed Jun 09, 2021 1:03 pm

Yeah i think the forum software is a bit old and could do with an update
User avatar
lundman
 
Posts: 981
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Emojis appear to make the forum go boom. :(

Postby BjarneDM » Thu Jun 10, 2021 10:56 am

The problem i two-fold :
1) from the error-page posted, it seems as if the forum is still running on MySQL 4.
MySQL 4 is EOL a loooong tiem ago & doesn't even turn up in the official eol notices any longer : https://endoflife.software/applications/databases/mysql
2) when creating a Mysql db table, one has to assign a text-encoding to it. If this isn't one of the ut8-variants, you get these types of crash.
3) when looking at the server headers, I see : X-Powered-By: PHP/5.6.36-pl0-gentoo ; so we've also got a seriously outdated and eol'ed version of php.

The correct course of action is :
1) export the databases
2) upgrade the whole server (it's a gentoo version). how to do that is described here : https://wiki.gentoo.org/wiki/Upgrading_Gentoo
3) alter the dbs to correctly support utf8 :
https://www.monolune.com/mysql-utf8-cha ... explained/
https://www.a2hosting.com/kb/developer- ... base-utf-8
BjarneDM
 
Posts: 3
Joined: Fri Jun 04, 2021 9:08 am


Return to Forums & Wiki Discussion

Who is online

Users browsing this forum: No registered users and 1 guest