Stuck at "replacing-x" While Replacing a Faulted Disk

All your general support questions for OpenZFS on OS X.

Stuck at "replacing-x" While Replacing a Faulted Disk

Postby monroo » Wed Jun 10, 2020 7:00 am

Hi all,

After a couple of power failures I noticed that one of the drives in my pool marked as FAULTED. I turned off my file server hosting the zpool and took out the problematic disk. Then ran WD health check software on it (using a Windows machine) and it seemed fine. So I reattached the disk to the file server and fired it up. Then I followed these steps I found on different guides over the internet. Notice that I'm using the same hard drive to replace the faulted media, like in the wiki.


1) sudo zpool detach tank GUIDOFTHEMEDIA(disk7)
2) sudo dd if=/dev/zero of=/dev/disk7 bs=1m
3) checked S.M.A.R.T. status to see if there are new errors. It seemed OK.
4) sudo gpt destroy /dev/disk7
4) sudo zpool replace tank GUIDOFTHEMEDIA(disk7) /dev/disk7

The pool immediately started resilvering and it took over 13h to complete. After resilvering completed I noticed that it still says "replacing-3" in zpool status commands output. I've waited for an additional 4 hours not being sure if it is still scrubbing or not but it still reports the same.

You can see the "zpool status" output here:

Code: Select all
  pool: tank
 state: DEGRADED
  scan: resilvered 3.47T in 0 days 13:11:57 with 0 errors on Wed Jun 10 14:44:53 2020
config:

   NAME                                              STATE     READ WRITE CKSUM
   tank                                              DEGRADED     0     0     0
     raidz2-0                                        DEGRADED     0     0     0
       media-CFA33156-FA5C-8F48-A9BE-20C3457A06C5    ONLINE       0     0     0
       media-1ECC4185-7FF7-BA40-8183-D3B76483B997    ONLINE       0     0     0
       media-F9EEBC0E-4971-1C44-82D2-CE53F1F351E4    ONLINE       0     0     0
       replacing-3                                   OFFLINE      0     0     0
         media-BA3144A5-292B-DC44-9057-81A5E893A995  OFFLINE      0     0     0
         disk7                                       ONLINE       0     0     0
       media-3B534A21-E296-A641-AE83-4189BD9E766A    ONLINE       0     0     0
       media-CF1B0813-426B-6E4B-A8D3-6F8471FE8C83    ONLINE       0     0     0



As you can see it is a raidz2 pool with 6 WD Red 4Tb disks running on OOX v1.9.4 and macOS v10.15.5.

Is there something I should do here manually, should I restart the file server?


Thanks in advance

Sincerely,
M
monroo
 
Posts: 7
Joined: Sat May 31, 2014 11:32 pm

Re: Stuck at "replacing-x" While Replacing a Faulted Disk

Postby lundman » Mon Jun 15, 2020 10:43 pm

Try "zpool detach GUIDOFTHEMEDIA media-BA3144A5-292B-DC44-9057-81A5E893A995"
User avatar
lundman
 
Posts: 817
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan


Return to General Help

Who is online

Users browsing this forum: No registered users and 4 guests