Read errors on stripe cause hang/crash.

All your general support questions for OpenZFS on OS X.

Re: Read errors on stripe cause hang/crash.

Postby zandr » Thu Mar 26, 2020 8:22 am

memtest86 passed with no issues. I needed to move ahead with rebuilding the array for my Photo library, but I'll take these two flaky disks and try to reproduce this on another box.

With the replacement disks, I've replicated the dataset back, and am most of the way through a scrub. Fingers Crossed. :D
zandr
 
Posts: 7
Joined: Thu Mar 19, 2020 6:19 am

Re: Read errors on stripe cause hang/crash.

Postby lundman » Fri Mar 27, 2020 1:58 pm

MCA Error Report ***\nCPU Machine Check Architecture Error Dump

That's the first time I've seen that, and appears to only talk about hardware, not software, so possibly ZFS isn't even involved - it certainly does
not contain a list of kexts like we are used to seeing.
User avatar
lundman
 
Posts: 817
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Read errors on stripe cause hang/crash.

Postby zandr » Sun Mar 29, 2020 9:17 am

lundman wrote:so possibly ZFS isn't even involved


Other than the "completely repeatable by importing the zpool and letting the scrub complete" bit, yeah.

- it certainly does not contain a list of kexts like we are used to seeing.


Because it isn't the same kind of crash. On the stripe, it would just lock up the machine without a panic. On the mirror, it managed to throw this.

I'll be able to do some additional testing this week. Need to get some work done using that hardware first.
zandr
 
Posts: 7
Joined: Thu Mar 19, 2020 6:19 am

Re: Read errors on stripe cause hang/crash.

Postby lundman » Wed Apr 01, 2020 11:46 pm

You could try disabling all the assembler versions (sysctl, setting the 4? to default/generic) in case it is something with saving registers that go wrong.
User avatar
lundman
 
Posts: 817
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Read errors on stripe cause hang/crash.

Postby 4ever6 » Mon Jun 08, 2020 7:25 am

lundman wrote:You could try disabling all the assembler versions (sysctl, setting the 4? to default/generic) in case it is something with saving registers that go wrong.


Curious about this - which sysctls are you referring to?
4ever6
 
Posts: 11
Joined: Fri Apr 07, 2017 7:24 pm

Re: Read errors on stripe cause hang/crash.

Postby lundman » Mon Jun 15, 2020 10:46 pm

There are four: zfs_vdev_raidz_impl icp_gcm_impl icp_aes_impl zfs_fletcher_4_impl

You set them to "generic" and hmm, standard? Whatever the most benign sounding one is :)
User avatar
lundman
 
Posts: 817
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Read errors on stripe cause hang/crash.

Postby jawbroken » Tue Jun 16, 2020 2:01 am

I have had two of these same crashes in the last month or so with the same enclosure. I recently upgraded to the latest Catalina versions, after lagging behind a bit. It's suspicious that we all have the same hardware, but given the generic error message it could be any combination of hardware, OS, or OpenZFS.
jawbroken
 
Posts: 10
Joined: Wed Apr 01, 2015 4:46 am

Previous

Return to General Help

Who is online

Users browsing this forum: No registered users and 3 guests