internal error: operation not supported on socket

All your general support questions for OpenZFS on OS X.

internal error: operation not supported on socket

Postby Sharko » Fri Nov 08, 2019 8:45 pm

So, I have an pool that consists of 2 x 4TB mirror on an external OWC dual Elite enclosure, connected via eSATA at the moment. The pool is called, not surprisingly, ELITE. The only dataset under ELITE is ENCRYPTED, which as you might guess is encrypted. Today I tried to add a new dataset under ENCRYPTED called MISC.

Code: Select all
Admins-Mac-Pro:~ adminkurt$ sudo sh
sh-3.2# zpool import -f ELITE
sh-3.2# zfs mount -l ELITE/ENCRYPTED
Enter passphrase for 'ELITE/ENCRYPTED':
sh-3.2#  zfs create ELITE/ENCRYPTED/MISC
internal error: Operation not supported on socket
Abort trap: 6
sh-3.2# zfs get readonly ELITE/ENCRYPTED
ELITE/ENCRYPTED  readonly  off     local

Am I tripping over something simple here? I have other datasets under ENCRYPTED that work just fine, and have been on the receiving end of zfs send operations for months (all done manually). You can see I checked to see if ENCRYPTED was readonly (and it's not).

Relevant system facts: running zfs 1.9.2 under Mojave.

Other weirdness: in the Finder, when I click on the ENCRYPTED volume in the sidebar it shows me my other working datasets (SHOME_BACKUP, JON_BACKUP, etc). However, when I try to drill down further into those datasets by clicking on them in main window of the finder they show as though they are empty. I have to explicitly do a 'zfs mount ELITE/ENCRYPTED/SHOME_BACKUP' command to see the contents of those child datasets under ELITE/ENCRYPTED. It seems like I have run into this before, but the search feature of the web site seems to be broken right now and I can't find my post about it and the responses - help ilovezfs?!
Posts: 109
Joined: Thu May 12, 2016 12:19 pm

Re: internal error: operation not supported on socket

Postby Sharko » Sat Nov 09, 2019 7:01 am

Edit: forgot to mention a few more relevant facts... this pool was created under zfs 1.7.2 (I think, it was one of the early ones that supported encryption), and I’ve never done a zpool upgrade on it. The problem is reproducible on this pool if I export and RE-import; haven’t tried rebooting yet.
Posts: 109
Joined: Thu May 12, 2016 12:19 pm

Re: internal error: operation not supported on socket

Postby lundman » Sun Nov 10, 2019 6:44 pm

That is odd, first thought was that you can not create a non-encrypted (plain) dataset under an encrypted one, but you didn't specify encryption, so it is supposed to inherit the value in that case.

Have you tried explicitly setting it when you create the dataset, ie, zfs create -o encryption=on ELITE/ENCRYPTED/MISC ?

I didn't have any issues with 1.9.3
Code: Select all
# zfs create -o encryption=on -o keyformat=passphrase tank/enc
Enter passphrase:
Re-enter passphrase:
# zfs create tank/enc/lower
# zfs list
tank            4.77M  18.9G  1.20M  /Volumes/tank
tank/enc        1.02M  18.9G   906K  /Volumes/tank/enc
tank/enc/lower   135K  18.9G   135K  /Volumes/tank/enc/lower

# zpool export tank
# zpool import -l tank
Enter passphrase for 'tank/enc':
1 / 1 keys successfully loaded

# zfs create tank/enc/lowerer
User avatar
Posts: 687
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Return to General Help

Who is online

Users browsing this forum: Google [Bot] and 1 guest