Page 1 of 1

Kernel panic 1.8.2 on 10.14.3

PostPosted: Sat Apr 06, 2019 1:34 pm
by gregthegeek
I'm suddenly having an issue with kernel panics. It started once I tried to copy an iMovie project file to ZFS volume. I can replicate it every time, copy file, crash within seconds. Also I tried to zip the project file and copy the zipped file to ZFS, now I can't even leave the ZFS disks attached to the mac, it keeps crashing while connected. Later today I'll connect it to LInux and remove the zip file and see if that helps.

This is the backtrace that comes up, if that helps. Just the top portion, but I can attach the full text if it helps.

Sat Apr 6 14:16:01 2019

*** Panic Report ***
panic(cpu 4 caller 0xffffff7f9247324e): blkptr at 0xffffff920dab7730 has invalid TYPE 56
Backtrace (CPU 4), Frame : Return Address
0xffffff927273b8d0 : 0xffffff80119aeb0d
0xffffff927273b920 : 0xffffff8011ae8653
0xffffff927273b960 : 0xffffff8011ada07a
0xffffff927273b9d0 : 0xffffff801195bca0
0xffffff927273b9f0 : 0xffffff80119ae527
0xffffff927273bb10 : 0xffffff80119ae373
0xffffff927273bb80 : 0xffffff7f9247324e
0xffffff927273bca0 : 0xffffff7f9372f32a
0xffffff927273bd00 : 0xffffff7f9375d1ea
0xffffff927273bd40 : 0xffffff7f9375d772
0xffffff927273bd80 : 0xffffff7f936c5b7b
0xffffff927273bde0 : 0xffffff7f936a914a
0xffffff927273be10 : 0xffffff7f9369dadc
0xffffff927273be50 : 0xffffff7f937629f8
0xffffff927273beb0 : 0xffffff7f9375e74f
0xffffff927273bf10 : 0xffffff7f9247ef16
0xffffff927273bfa0 : 0xffffff801195b0ce
Kernel Extensions in backtrace:
dependency: net.lundman.spl(1.8.1)[F931881B-FB27-3712-8C57-4DF33E9CCD48]@0xffffff7f92471000

Re: Kernel panic 1.8.2 on 10.14.3

PostPosted: Sun Apr 07, 2019 5:19 pm
by lundman
We only need the top portion, but it would help if you set keepsyms=1 in bootargs, so we get resolved names rather than just addresses.

Re: Kernel panic 1.8.2 on 10.14.3

PostPosted: Mon Apr 08, 2019 12:39 pm
by gregthegeek
of course, that makes sense. I wont have a ton of time this next week to test, but soon as I can, I'll run this on my other mac and try to reproduce with that boot arg. My main system is back on 1.7.4 and working well for now, including copying those files. How do you set boot args on Mac anyway? I can google it.

Re: Kernel panic 1.8.2 on 10.14.3

PostPosted: Tue Apr 09, 2019 11:20 pm
by lundman
Usually just "sudo nvram boot-args="keepsyms=1"

but check you don't have it set to something special, and just add the keepsyms part.

Re: Kernel panic 1.8.2 on 10.14.3

PostPosted: Sat Jun 01, 2019 11:45 am
by gregthegeek
Hi, I just wanted to follow up on this. I finally took some time to update everything and have no crashing issues now. (so far)
I updated to 10.14.5 and O3X to 1.9.0, seems to be working great.
The only thing I still have is something weird with nested file systems in Finder, which are common on my linux disks imported. but I posted separately about that I think. If I run into any panics, I'll try the boot args and report back.