zpool upgrade command

All your general support questions for OpenZFS on OS X.

zpool upgrade command

Postby calbear88 » Sat Jun 02, 2018 9:02 pm

Hi, I originally created my pools in 2016 using OpneZFS on OS X version 1.5.2. I'm running the newest version 1.7.2 currently. I use zetawatch, it shows a message "supported features are disabled", and if a run "zpool status" in terminal, I see a message about supported features not being enabled as well.

Some supported features are not enabled on the pool. The pool can
still be used, but some features are unavailable.
action: Enable all features using 'zpool upgrade'. Once this is done,
the pool may no longer be accessible by software that does not support
the features. See zpool-features(5) for details.


If I run the zpool upgrade command I see the following information about which features are not enabled.

POOL FEATURE
---------------
HD2
device_removal
obsolete_counts
zpool_checkpoint"

[/i]

I think the "zpool upgrade" command enables the features flags that allows these features to work. From the wiki page, it seems that openzfs on osx has always used is using zfs pool version 28, so does upgrade command actually upgrade the pool version?



Thanks so much
calbear88
 
Posts: 23
Joined: Sun Mar 08, 2015 3:01 pm

Re: zpool upgrade command

Postby lundman » Sun Jun 03, 2018 7:30 pm

O3X can import pool version 28, and that version is basically (famously) the "newest" pool version that "all" platforms can handle, that is both OpenZFS (illumos, linux, freebsd, osx and windows) as well as OracleZFS (solaris), since after pool version 28, OracleZFS went on to 29, 30, 31, ...

whereas OpenZFS went to pool version 5000 - or rather, "feature flags". Where each new feature would be a flag, that can be enabled, disabled and active. That way you can chose what you want to enable and use, and control any incompatibilities.

Right now, your pool version IS "feature flags" and you are using all feature-flags, except for: device_removal, obsolete_counts, zpool_checkpoints.

Now, if you DO "zpool upgrade $pool" it will enable those 3 features as well to be feature complete with latest O3X version, and ZFS is free to use those features on your pool. You will no longer be able to go back to a ZFS version without those features. Ie, you can not go back to 1.5.2.

In most cases, you should think regarding whether or not really need the features "device_removal, obsolete_counts, zpool_checkpoints", and if so, upgrade. Otherwise, perhaps don't upgrade, as you will have better compatibility to older O3X, as well as, other platforms. Until the day comes that you feel confident you will not need to go back, and/or, all other platforms also contain said features.
User avatar
lundman
 
Posts: 486
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan


Return to General Help

Who is online

Users browsing this forum: No registered users and 2 guests

cron