Not working in macOS 10.13 High Sierra (fixed)

All your general support questions for OpenZFS on OS X.

Not working in macOS 10.13 High Sierra (fixed)

Postby rahvee » Mon Nov 13, 2017 7:42 am

I was previously running macOS 10.12 and O3X 1.6.1. I tried using the 1.7.0 installer, but it said macOS 10.13 was required. So I upgraded to macOS 10.13, and found O3X 1.6.1 was not working anymore. (Not surprising, because 1.6.1 is not supposed to work on 10.13). So then I ran the 1.7.0 installer, and got

Code: Select all
"System Extension Blocked. A program tried to load new system extension(s) signed by Joergen Lundman". If you want to enable these extensions, open Security & Privacy System Preferences."


I don't see anything that looks like I should change it in the Security & Privacy dialog, so I closed the dialog without changing anything.

Then I searched these forums, and found a suggestion to uninstall O3X 1.6.1 by downloading the 1.6.1 dmg file and using the uninstallation scripts, and then reinstall 1.7.0 using the pkg. I did this, but still have the same result.

If I go to Terminal and type:

Code: Select all
root# zpool status
Failed to load ZFS module stack.
Load the module manually by running '/sbin/kextload /Library/Extensions/zfs.kext' as root.
The /dev/zfs device is missing and must be created.
Try running 'udevadm trigger' as root to create it.


If I try the above suggestions, I get:

Code: Select all
root# /sbin/kextload /Library/Extensions/zfs.kext
/Library/Extensions/zfs.kext failed to load - (libkern/kext) dependency load failed; check the system/kernel logs for errors or try kextutil(8).


and

Code: Select all
root# udevadm trigger
-sh: udevadm: command not found


Per suggestion of lundman, I tried:

Code: Select all
root# cd /Library/Extensions/

root# kextutil spl.kext zfs.kext
Kext rejected due to system policy: <OSKext 0x7ff41e926fa0 [0x7fff9360f570]> { URL = "file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/", ID = "net.lundman.kernel.dependencies.30" }
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Kext rejected due to insecure location: <OSKext 0x7ff41d40d7f0 [0x7fff9360f570]> { URL = "file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/", ID = "net.lundman.kernel.dependencies.30" }
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Diagnostics for /Library/Extensions/spl.kext:
Dependency Resolution Failures:
    Only incompatible kexts found for these libraries:
        net.lundman.kernel.dependencies.30

Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Diagnostics for /Library/Extensions/zfs.kext:
Dependency Resolution Failures:
    Indirect dependencies can't be resolved:
        net.lundman.spl



Help please! I'd really like to get zfs back up and running...
Last edited by rahvee on Tue Nov 14, 2017 11:51 am, edited 1 time in total.
rahvee
 
Posts: 6
Joined: Wed May 25, 2016 4:40 am

Re: Not working in macOS 10.13 High Sierra

Postby lundman » Tue Nov 14, 2017 12:38 am

Uninstall ZFS, reboot, then install 1.7.0 - the shim kext is getting in the way
User avatar
lundman
 
Posts: 315
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Not working in macOS 10.13 High Sierra

Postby rahvee » Tue Nov 14, 2017 3:59 am

Thank you, but as described in the post, I already uninstalled 1.6.1 and then reinstalled 1.7.0. The only thing I can think of to do more is to uninstall 1.7.0 also. Is there some way to uninstall 1.7.0?
rahvee
 
Posts: 6
Joined: Wed May 25, 2016 4:40 am

Re: Not working in macOS 10.13 High Sierra (fixed)

Postby rahvee » Tue Nov 14, 2017 12:00 pm

Ah-hah!

When the pop-up dialog says "System Extension Blocked," and it opens the Security & Privacy system preferences pane, it does not necessarily show the "General" tab. You need to go to the General tab. In the bottom section of that dialogue, it should say an application was blocked for Joergen Lundman, and you should be able to click "Allow." If that button is available, it should solve the problem.

In my case, I swear, yesterday there wasn't a button to allow a blocked application by Joergen Lundman. I don't know what I did differently today, to make the button appear, but today the button was there, and that fixed the problem.
rahvee
 
Posts: 6
Joined: Wed May 25, 2016 4:40 am


Return to General Help

Who is online

Users browsing this forum: No registered users and 1 guest