Can't install under High Sierra

All your general support questions for OpenZFS on OS X.

Can't install under High Sierra

Postby AnWa » Fri Nov 10, 2017 7:55 am

Hi!

After upgrading to High Sierra, ZFS will not load. Terminal output follows:
Anders-MC:log anderswa$ sudo zpool import
Password:
Failed to load ZFS module stack.
Load the module manually by running '/sbin/kextload /Library/Extensions/zfs.kext' as root.
The /dev/zfs device is missing and must be created.
Try running 'udevadm trigger' as root to create it.
Anders-MC:log anderswa$ cd /dev
Anders-MC:dev anderswa$ cd zfs
-bash: cd: zfs: No such file or directory
Anders-MC:dev anderswa$ sudo udevadm trigger
sudo: udevadm: command not found
Anders-MC:dev anderswa$ sudo /sbin/kextload /Library/Extensions/zfs.kext
/Library/Extensions/zfs.kext failed to load - (libkern/kext) dependency load failed; check the system/kernel logs for errors or try kextutil(8).


So I tried to do a reinstall using the 1.7.0 installer, but no. Log follows:
2017-11-10 16:48:34+01 Anders-MC installd[16445]: PackageKit: Removing client PKInstallDaemonClient pid=17024, uid=501 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
2017-11-10 16:48:34+01 Anders-MC installd[16445]: PackageKit: Done with sandbox removals
2017-11-10 16:48:34+01 Anders-MC Installer[17024]: Install failed: Installeraren stötte på ett fel som förhindrade installationen. Kontakta programtillverkaren och be om assistans.
2017-11-10 16:48:34+01 Anders-MC Installer[17024]: IFDInstallController 201110 state = 8
2017-11-10 16:48:34+01 Anders-MC Installer[17024]: Displaying 'Install Failed' UI.
2017-11-10 16:48:34+01 Anders-MC Installer[17024]: 'Install Failed' UI displayed message:'Installeraren stötte på ett fel som förhindrade installationen. Kontakta programtillverkaren och be om assistans.'.
2017-11-10 16:48:48+01 Anders-MC Installer[17024]: Package Removal: Package is not in downloads directory. Not offering removal.
2017-11-10 16:48:48+01 Anders-MC Installer[17024]: Package Removal: Package cannot be removed.


Any and all help appreciated.
AnWa
 
Posts: 9
Joined: Tue Nov 04, 2014 9:57 am

Re: Can't install under High Sierra

Postby Jimbo » Sat Nov 11, 2017 2:15 am

Download the 1.6.1 DMG. Open/mount that. Run the uninstaller script from the 1.6.1 image. Reboot (maybe not necessary?). Install 1.7.0 from PKG.

That worked for me.

James
Jimbo
 
Posts: 5
Joined: Sun Sep 17, 2017 5:12 am

Re: Can't install under High Sierra

Postby lundman » Sun Nov 12, 2017 5:02 pm

Yes, you need the kext from 1.7.0 instead, that should load. If you want to see why they do not load, use "kextutil spl.kext zfs.kext" after cd'ing into /Library/Extensions/
User avatar
lundman
 
Posts: 363
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Can't install under High Sierra

Postby AnWa » Mon Nov 13, 2017 12:46 pm

Thanks, both of You.

Unfortunately, it failed. Following the last suggestion, I got this text back:
Anders-MC:Extensions anderswa$ sudo kextutil spl.kext zfs.kext
Kext rejected due to system policy: <OSKext 0x7ff8b4c4eef0 [0x7fff9aa7a570]> { URL = "file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/", ID = "net.lundman.kernel.dependencies.30" }
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Kext rejected due to insecure location: <OSKext 0x7ff8b4d2fd30 [0x7fff9aa7a570]> { URL = "file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/", ID = "net.lundman.kernel.dependencies.30" }
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Diagnostics for /Library/Extensions/spl.kext:
Dependency Resolution Failures:
Only incompatible kexts found for these libraries:
net.lundman.kernel.dependencies.30

Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
Rejecting invalid/inauthentic kext for bundle id net.lundman.kernel.dependencies.30 at location file:///Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/.
/Library/StagedExtensions/Library/Extensions/spl.kext - no compatible dependency found for net.lundman.kernel.dependencies.30.
Diagnostics for /Library/Extensions/zfs.kext:
Dependency Resolution Failures:
Indirect dependencies can't be resolved:
net.lundman.spl


It seems that my Mac refuses to load the signed software. I have tried repeatedly to allow the software in the Securities settings panel, bu nothing seems to happen.
AnWa
 
Posts: 9
Joined: Tue Nov 04, 2014 9:57 am

Re: Can't install under High Sierra

Postby Jimbo » Mon Nov 13, 2017 7:32 pm

All 3rd party(?) kexts now need to be explicitly allowed now, regardless of whether they're signed with a valid key.

Have you allowed the kexts to be loaded - System Preferences, Security and Privacy, General? You should have seen a pop-up.

As has been noted elsewhere, this has to be done "physically" as it doesn't seem to work (reliably?) via screen sharing or remote management.

James
Jimbo
 
Posts: 5
Joined: Sun Sep 17, 2017 5:12 am

Re: Can't install under High Sierra

Postby lundman » Tue Nov 14, 2017 12:36 am

Looks like you have the shim kext already loaded, you may need to reboot, then it should load the kexts (assuming the old kexts are not still in /Library/Extensions)
User avatar
lundman
 
Posts: 363
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Can't install under High Sierra

Postby AnWa » Tue Nov 14, 2017 6:20 am

Jimbo wrote:All 3rd party(?) kexts now need to be explicitly allowed now, regardless of whether they're signed with a valid key.

Have you allowed the kexts to be loaded - System Preferences, Security and Privacy, General? You should have seen a pop-up.

As has been noted elsewhere, this has to be done "physically" as it doesn't seem to work (reliably?) via screen sharing or remote management.

James


The "allow all" option has disappeared; probably as part of the OS upgrade. I now have to allow non-Apple approved software manually, but when I click the Allow button, nothing happens. These are differences compared to before the OS upgrade.
AnWa
 
Posts: 9
Joined: Tue Nov 04, 2014 9:57 am

Re: Can't install under High Sierra

Postby AnWa » Tue Nov 14, 2017 6:43 am

lundman wrote:Looks like you have the shim kext already loaded, you may need to reboot, then it should load the kexts (assuming the old kexts are not still in /Library/Extensions)


Rebooted, but to no effect:
Anders-MC:~ anderswa$ sudo zpool import array
Failed to load ZFS module stack.
Load the module manually by running '/sbin/kextload /Library/Extensions/zfs.kext' as root.
The /dev/zfs device is missing and must be created.
Try running 'udevadm trigger' as root to create it.
Anders-MC:~ anderswa$ sudo /sbin/kextload /Library/Extensions/zfs.kext
/Library/Extensions/zfs.kext failed to load - (libkern/kext) dependency load failed; check the system/kernel logs for errors or try kextutil(8).
Anders-MC:~ anderswa$ sudo udevadm trigger
sudo: udevadm: command not found
Anders-MC:~ anderswa$ sudo kextutil /Library/Extentions/zfs.kext
Can't stat /Library/Extentions/zfs.kext - No such file or directory.
AnWa
 
Posts: 9
Joined: Tue Nov 04, 2014 9:57 am

Re: Can't install under High Sierra

Postby rahvee » Tue Nov 14, 2017 12:09 pm

This may help:

Go to the Security & Privacy window of System Preferences. Go to the General tab. In the bottom half of the window, it should say "application was blocked for Joergen Lundman" and have an "Allow" button. If you have that, it should solve it. If you don't have it, try fiddling around to make it appear - Maybe closing & re-opening the dialogue. Maybe re-running the installer. Maybe trying some "sudo zpool" commands, and then going back into the system preferences dialogue.

I don't know why the button wasn't there for me before, and I don't know what caused it to appear later, but I know I was having a very similar problem to yours, and I specifically looked for that button (it wasn't there), and then a day later I looked again, and it was there. After I was able to click the button, the problem was solved.
rahvee
 
Posts: 6
Joined: Wed May 25, 2016 4:40 am

Re: Can't install under High Sierra

Postby lundman » Tue Nov 14, 2017 4:58 pm

It would have to be with spl and zfs kexts on the commandliine, ie

kextutil /Library/Extensions/spl.kext /Library/Extensions/zfs.kext/

Or hmm, maybe it can handle dependency when they are installed.

That stat reports error seems to suggest the kext in not installed?

The udev trigger garbage is left over from ZOL days, we should really delete that print.
User avatar
lundman
 
Posts: 363
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Next

Return to General Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron