iTunes in 10.11.3 struggling to write

All your general support questions for OpenZFS on OS X.

Re: iTunes in 10.11.3 struggling to write

Postby Brendon » Sat Jan 27, 2018 3:50 am

Hi,

The current “master” code contains some very nice fixes that have made a lot of apple software run a lot faster including iPhoto.

The only way to use that code right now is to build it yourself, however the next release will include these improvements.

Brendon
Brendon
 
Posts: 277
Joined: Thu Mar 06, 2014 12:51 pm

Re: iTunes in 10.11.3 struggling to write

Postby RobRehnmark » Sun Feb 04, 2018 1:44 pm

Sluggish iTunes writes are the reason I'd like to put my media on a zVol formatted to HFS+.
I'd like to hear input from other's on this issue.
Super grateful to the people developing OpenZFS on OS X!
RaidZ2 working well for storing my data, OS X Server share for Time Machine, FCPX, iTunes, Photos, etc. on my Hackinstosh.
RobRehnmark
 
Posts: 51
Joined: Sat Oct 17, 2015 12:23 am

Re: iTunes in 10.11.3 struggling to write

Postby Ikukuru » Sun Feb 04, 2018 2:50 pm

Ikukuru
 
Posts: 14
Joined: Mon Sep 22, 2014 4:17 pm

Re: iTunes in 10.11.3 struggling to write

Postby calbear88 » Wed Feb 07, 2018 10:17 am

I used to have my iTunes media folder stored on my ZFS volume. Inside this folder is the "mobile applications" folder that contains my downloaded iOS apps from the app store. When I update the ios apps in iTunes to a new version, normally iTunes overwrites the old app with the new version and moves the old version to the trash. When the mobile applications folder is on the ZFS volume, the updates fail, giving me a file permissions error. I tried moving my iTunes media folder to my APFS volume, but the permission errors persisted and I couldn't update the apps. I ended having to erase my itunes media library and setup a new library in order to get the apps to update. I

I don't remember the exact error message iTunes gave me, but it seemed that the download completed, but when it tried to overwrite the file, it would fail, so my donwload queue showed a bunch of failed updates. I have several hundred gigabyte iTunes media folder, so I'm reluctant to it to my ZFS volume again to recreate the error message because I may need to delete the library and create it again from scratch

Hope this helps troubleshoot the issue.

Thanks.
calbear88
 
Posts: 17
Joined: Sun Mar 08, 2015 3:01 pm

Re: iTunes in 10.11.3 struggling to write

Postby e8vww » Fri Feb 16, 2018 3:28 am

I wanted to update and say that all i/o operations are faster having reduced arc_max to 1gb and using the current master. There remains a large performance hit vs HFS, at least 50%. This isn't a problem for most HTPC tasks other than backups. I am on itunes 12.7.3 now and its working good for music and iphone backups. Hopefully performance will be a priority this year now that things seem stable.
e8vww
 
Posts: 51
Joined: Fri Nov 24, 2017 2:06 pm

Previous

Return to General Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron