File Sharing - Issue with Special Characters in Folder Name

All your general support questions for OpenZFS on OS X.

File Sharing - Issue with Special Characters in Folder Name

Postby mstan » Thu Dec 10, 2015 5:53 am

I am trying once again to share a media library on a Mac Pro [El Cap] ZFS pool to a WIN7 client. It almost works except files in folders are invisible where the folder name has a special character found in non English languages (like a tilde over the a in Portuguese or the German umlaut). This problem happens on both the remote WIN7 client machine and remote Mac client machines (no problem with the folders on the host Mac machine). The same library on a shared HFS+ volume has no such problem. I could edit the library folders to remove the characters but I shouldn't have to. What is the fix? Is there a ZFS dataset property that controls this?

Update: If I turn off SMB sharing and leave only AFP on the Mac, then I can see special character folders and files correctly on the remote Mac (but of course nothing on WIN7 because SMB is off). HFS+ folders and files with the special characters don't exhibit this problem. So there must be something that HFS+ file system passes to SMB that ZFS does not. But what?
Mac Pro 4,1->5,1; single 2.66 cpu; 32GB ecc ram; Sonnet usb 3.1 PCIe card; Firmtek eSATA PCIe card; Radeon 5770
mstan
 
Posts: 38
Joined: Sun May 18, 2014 2:36 pm

Re: File Sharing - Issue with Special Characters in Folder N

Postby mstan » Mon Dec 14, 2015 10:36 pm

Solved. Just remembered that I forgot to set normalization to formD. Sorry.
Mac Pro 4,1->5,1; single 2.66 cpu; 32GB ecc ram; Sonnet usb 3.1 PCIe card; Firmtek eSATA PCIe card; Radeon 5770
mstan
 
Posts: 38
Joined: Sun May 18, 2014 2:36 pm


Return to General Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron