Want data? - Panic Monterey/Catalina/Ubuntu on import

Developer discussions.

Want data? - Panic Monterey/Catalina/Ubuntu on import

Postby zfsosxuser » Sun Mar 06, 2022 10:05 pm

I am not looking for help to fix this. I am going to erase these disks and start over. But before I do, does any dev want me to collect data for future dev/debugging?

Details:
* new mirror pool created on Monterey using a new install of 2.1.0.
* Encrypted, with several data sets.
* Connected via USB-3 case.
* Copied a TB or so from APFS disk before OS became unstable and I rebooted. Continued copy until this repeated with another reboot. This happened 2 or 3 times until now it kernel panics and immediately reboots with 'zfs mount -a' command. I can import the pool and load the encryption key, but 'zfs mount -a' causes an immediate reboot.
* Tried to mount on a brand new install of Ubuntu server 21.10 on an old MacBook connected by USB-2. Same reboot.
* Tried to mount one disk of the mirror on a nearly new install of Catalina (dosdude1 patched) with 2.1.0 on an old Mac Mini, but connected via SATA (using optical SATA port). Same reboot.

If any dev wants debugging data, please send me the commands you would like me to run. Or if you want me to troubleshoot a bit with the debugger, please give me an idea of the commands to run and what to look for. I am a dev and can use a debugger, but I am not familiar with kernel, driver, or ZFS code.

Thanks
zfsosxuser
 
Posts: 2
Joined: Wed Apr 03, 2019 8:45 am

Return to OpenZFS on OS X Development

Who is online

Users browsing this forum: No registered users and 1 guest

cron