about 0.8.0 build…

Developer discussions.

about 0.8.0 build…

Postby tangles » Fri Aug 21, 2020 5:25 am

Hi Lundy,

Code: Select all
madmin@TrashPro ~ % sudo /usr/local/bin/zpool create heregoes /dev/disk2
dyld: Library not loaded: /usr/local/opt/gettext/lib/libintl.8.dylib
  Referenced from: /usr/local/bin/zpool
  Reason: image not found
zsh: abort      sudo /usr/local/bin/zpool create heregoes /dev/disk2
madmin@TrashPro ~ %


just me? or is something broken?

I looked in /usr/local/ and I have no opt folder…

Code: Select all
madmin@TrashPro ~ % ls -l  /usr/local/opt
total 0
lrwxr-xr-x  1 madmin  admin  27 19 Jul 22:16 ipmitool -> ../Cellar/ipmitool/1.8.18_3
lrwxr-xr-x  1 madmin  admin  23 27 Jul 23:52 netperf -> ../Cellar/netperf/2.7.0
lrwxr-xr-x  1 madmin  admin  28 19 Jul 22:16 openssl -> ../Cellar/openssl@1.1/1.1.1g
lrwxr-xr-x  1 madmin  admin  28 19 Jul 22:16 openssl@1.1 -> ../Cellar/openssl@1.1/1.1.1g
lrwxr-xr-x  1 madmin  admin  27 27 Mar 18:58 smartmontools -> ../Cellar/smartmontools/7.1
madmin@TrashPro ~ %


I did have 1.94 installed. I ran uninstall-openzfsonosx.sh from the 1.94 disk image, restarted and then installed OpenZFSonOsX-0.8.0-Catalina-10.15.pkg

I was also going to ask about attributes, in particular: casesensitivity=insensitive and normalization=formD and whether you suggest something new that's more aligned to APFS' defaults?

I intended to test using Howard's (eclectic.com) Apfelstrudel app with a file called:
café.jpg → (hex) → 63 61 66 c3 a9 2e 6a 70 67
and
café.jpg → (hex) → 3 61 66 65 cc 81 2e 6a 70 67
which use different Unicode characters for the accent, and see how they got along in the same folder on a ZFS dataset…

UPDATE: both APFS and ZFS don't like the above existing in the same folder. Can't argue with that.

Didn't get that far obviously and so I'll wait to hear back.

Great work mate… Champion effort!
Last edited by tangles on Tue Sep 01, 2020 4:42 am, edited 1 time in total.
tangles
 
Posts: 176
Joined: Tue Jun 17, 2014 6:54 am

Re: about 0.8.0 build…

Postby tangles » Sun Aug 30, 2020 7:18 am

I had to use brew to install gettext before zpool --version would work…

No one else got this issue using the 0.8.0 test build/pkg?
tangles
 
Posts: 176
Joined: Tue Jun 17, 2014 6:54 am

Re: about 0.8.0 build…

Postby CipherF15 » Sun Aug 30, 2020 11:24 am

Same problem here, I'm "glad" to see it's not just me being a newbie...
CipherF15
 
Posts: 8
Joined: Thu Aug 27, 2020 9:12 am

Re: about 0.8.0 build…

Postby lundman » Sun Aug 30, 2020 4:16 pm

Ah hmm, well that sucks.

Wonder how we should solve this, requiring people to install brew first is not ok.
User avatar
lundman
 
Posts: 765
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: about 0.8.0 build…

Postby tangles » Tue Sep 01, 2020 4:24 am

oh…

I thought it was just a static v dynamic linking thingy at compile time that slipped through…
tangles
 
Posts: 176
Joined: Tue Jun 17, 2014 6:54 am

Re: about 0.8.0 build…

Postby lundman » Wed Sep 02, 2020 1:20 am

It's tricky, I was using brew libraries, but you can't just move them around alas.

I have produced a new pkg which should fix that.
User avatar
lundman
 
Posts: 765
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: about 0.8.0 build…

Postby tangles » Wed Sep 02, 2020 3:43 am

Uninstalled gettext
installed OpenZFSonOsX-0.8.0-Catalina-10.15

nice…
tangles
 
Posts: 176
Joined: Tue Jun 17, 2014 6:54 am

Re: about 0.8.0 build…

Postby tangles » Sun Sep 06, 2020 3:43 pm

Am liking the 0.8.0 build.

Little quirky to get a pool to import though…

In case others are having a play:

Code: Select all
√ ~ % sudo zpool status
  pool: heregoes
 state: ONLINE
config:

   NAME        STATE     READ WRITE CKSUM
   heregoes    ONLINE       0     0     0
     disk2     ONLINE       0     0     0

errors: No known data errors
√ ~ % sudo zpool export heregoes
Volume heregoes on disk3s1 unmounted
√ ~ % sudo zpool import heregoes             
cannot import 'heregoes': no such pool available
?1 ~ % sudo zpool import -f heregoes
cannot import 'heregoes': no such pool available
?1 ~ % diskutil list physical
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         121.1 GB   disk0s2

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            heregoes               *500.1 GB   disk2

√ ~ % sudo zpool import heregoes -d /dev/disk2
√ ~ %


I have to use the -d attribute and point to the disk before it appears on the desktop.

Am using: 10.15.6 (19G2021) with a single USBc Samsung T7 500GB flash drive for testing.

Cheers
tangles
 
Posts: 176
Joined: Tue Jun 17, 2014 6:54 am

Re: about 0.8.0 build…

Postby tangles » Sun Sep 06, 2020 3:52 pm

Am I correct in thinking the Finder doesn't know much about 0.8.0 when mounted yet?

I purposefully yanked the disk, nothing appeared in Finder and icon remained on Desktop.

Zpool command knows though:
Code: Select all
√ ~ % zpool status
  pool: heregoes
 state: SUSPENDED
status: One or more devices are faulted in response to IO failures.
action: Make sure the affected devices are connected, then run 'zpool clear'.
   see: https://zfsonlinux.org/msg/ZFS-8000-HC
config:

   NAME        STATE     READ WRITE CKSUM
   heregoes    UNAVAIL      0     0     0  insufficient replicas
     disk2     REMOVED      0     0     0
errors: List of errors unavailable: pool I/O is currently suspended


Finder works normally, just with a ghost icon of the mount present.
I dragged an empty folder to the ghost mount to see what would happen and the progress bar to copy the folder popped up as expected.
Clearly it didn't do anything and when I went to cancel the copy, the Finder did not close the copy progress window.

I've since force quit the Finder which will now not respawn, as I suspect the copy process is stopping it.
Am not able to load console to give any more info… Consolation.app appears locked up as well.. (spinning ball)
More apps not starting to hang so better post this quick! ;)
tangles
 
Posts: 176
Joined: Tue Jun 17, 2014 6:54 am

Re: about 0.8.0 build…

Postby lundman » Mon Sep 07, 2020 9:31 pm

We removed /dev/ from the list of paths to search for - due to the disk renumbering OSX likes to do, and if you have cache/log device being used, it can destroy unrelated disks.

So yes, if you want to use /dev/disk names, use

zpool import -d /dev/ NAME

but we recommend using InvariantDisk paths, ie /var/run/disk/by-* which should find pools automatically.
User avatar
lundman
 
Posts: 765
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Next

Return to OpenZFS on OS X Development

Who is online

Users browsing this forum: No registered users and 2 guests

cron