ZFS on Boot still working above Capitan?

Here you can discuss every aspect of OpenZFS on OS X. Note: not for support requests!

ZFS on Boot still working above Capitan?

Postby DanielSmedegaardBuus » Tue Feb 26, 2019 11:27 pm

Hey :)

I'm preparing a macOS NAS setup on a mini with an internal SSD and a bunch of external USB drives. My plan was to just create my pool on the USB drives that are already assigned for this task, but for the last day or so I've been looking at options for doing cloud backup (cheaply).

I've been following Backblaze's blogs for quite a while, and really think what they're doing is awesome. I'd love to be able to use their service (not the B2 one; too expensive), but I've tried to back up stuff that's on ZFS, and their app won't do it.

This got me wondering if it might feel different if the pool was actually the root filesystem. So I thought about this whole installing macOS on a zpool thing (https://openzfsonosx.org/wiki/ZFS_on_Boot), but I do notice that the guide is using El Capitan in its examples, so I'm wondering if it's still a (supported) thing. I've been setting up Mojave on the mini, but I'm not at all married to it. I'm actually running Yosemite on another mini — the only requirements I have for the OS version is that I can run ZFS on it, and that homebrew works enough for me to install GNU coreutils and other shell tools that I use extensively. Oh, and the mini in question is a 2014 one, so El Capitan will install on it if necessary.

Thanks!
DanielSmedegaardBuus
 
Posts: 33
Joined: Thu Aug 28, 2014 11:00 pm

Re: ZFS on Boot still working above Capitan?

Postby lundman » Wed Feb 27, 2019 12:54 am

I believe it still works, but has the fonts problem still - have not managed to find out the magic there. Which effectively it is useless. Booting a ZVOL is a realistic path I believe, although I have not done so myself.
User avatar
lundman
 
Posts: 705
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: ZFS on Boot still working above Capitan?

Postby DanielSmedegaardBuus » Wed Feb 27, 2019 9:27 pm

Guess I'll have to give it a try :) I used the guide to get Linux on ZFS a while back, and it worked out fine.

What is this font problem that you're speaking of, though?

Thanks!
DanielSmedegaardBuus
 
Posts: 33
Joined: Thu Aug 28, 2014 11:00 pm

Re: ZFS on Boot still working above Capitan?

Postby lundman » Thu Feb 28, 2019 4:09 pm

When you boot it seems to have issues reading or validating some fonts. So if you open Chrome, and connect to google, you will see nothing.
https://github.com/openzfsonosx/zfs/issues/544
Admittedly, I've not booted on zfs for a year, so I don't know for sure if it is still there. But that does seem likely.
User avatar
lundman
 
Posts: 705
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: ZFS on Boot still working above Capitan?

Postby DanielSmedegaardBuus » Sun Mar 03, 2019 12:36 am

Thank you so much for your replies, Lundman!

If the font problem doesn't interfere with the general UI, I can live with that, since this machine will work as a NAS, so 99% of my access to it will be ssh anyway :)

Thanks again! Enjoy your Sunday :)
DanielSmedegaardBuus
 
Posts: 33
Joined: Thu Aug 28, 2014 11:00 pm

Re: ZFS on Boot still working above Capitan?

Postby BrindaSharma » Wed Feb 26, 2020 1:12 am

At the point when you boot it appears to have issues perusing or approving a few textual styles. So on the off chance that you open Chrome, and interface with google, you will see nothing.
BrindaSharma
 
Posts: 1
Joined: Wed Feb 26, 2020 1:09 am

Re: ZFS on Boot still working above Capitan?

Postby FadingIntoBlue » Sat Feb 29, 2020 6:49 pm

I've been following Backblaze's blogs for quite a while, and really think what they're doing is awesome. I'd love to be able to use their service (not the B2 one; too expensive), but I've tried to back up stuff that's on ZFS, and their app won't do it.


My Backblaze backup treats my Pool like an external disk (directly connected to the computer I'm backing up) and backs up without difficulty. Have you tried setting

Code: Select all
com.apple.mimic_hfs    on 


I have some other non standard settings, but that is the one I'm guessing lets it work.
FadingIntoBlue
 
Posts: 44
Joined: Tue May 27, 2014 12:25 am

Re: ZFS on Boot still working above Capitan?

Postby tocnaza » Wed Mar 04, 2020 9:59 am

Thanks for the answer.
tocnaza
 
Posts: 1
Joined: Wed Mar 04, 2020 9:58 am

Re: ZFS on Boot still working above Capitan?

Postby Ganesh1199 » Fri Mar 27, 2020 11:02 pm

Helpful information
Ganesh1199
 
Posts: 1
Joined: Fri Mar 27, 2020 10:58 pm


Return to General Discussions

Who is online

Users browsing this forum: Google [Bot] and 1 guest