v1.6.1 issues on Mavericks

We won't tell.

v1.6.1 issues on Mavericks

Postby nodarkthings » Tue Mar 14, 2017 3:12 am

EDIT: OpenZFS 1.7.2 fixed the issue!

I'm posting this here, to be on the safe side, but after many trials I'm quite sure the issue has nothing to do with my computer being a Hackintosh… ;)

I had various issues after updating to v1.6.1 on Mavericks: to summarize, pools created after 1.6.1 prevent the computer from booting if the drive they're on is attached to the computer! (be it the boot drive or not)
Old pools don't create any problem and work ok.

• It happened once on my boot SSD (that had no ZFS pool on it before), where I created a pool for my VMs — I first thought the VMs could be the problem, so I replaced the pool with a HFS partition and it went back ok
• Now it has happened again to the HD where my long time first pool resides, after adding a partition to another existing pool, I had the same issue (impossible to boot with the HD attached)
=> the problem is gone when I destroy the recent pools and delete the partitions...
• After I fixed that, I created a new pool but to my amazement, it didn't mount after reboot, but the underlying HFS partition did instead! (I tried twice, putting data in the pool or not) — if I eject the HFS partition, I can manually import the pool and the data is still there…

I reinstalled v1.5.2, first on another drive, then to my SSD, in both cases, those problems are gone, so I have no doubt it's related to v1.6.1 (the Mavericks build?).
Note that I use drives with lots of HFS partitions and some ZFS pools. My use of ZFS is very limited for the moment, I'm far from the mirror or raidz thing…

As for that issue: I've controlled every accessible information and saw no error anywhere (pools status, Console).
Last edited by nodarkthings on Fri Oct 19, 2018 2:25 am, edited 1 time in total.
Posts: 150
Joined: Mon Jan 26, 2015 10:32 am

Re: v1.6.1 issues on Mavericks

Postby Brendon » Wed Mar 15, 2017 4:01 pm


I created a 10.9.0 VM, installed 1.6.1, created a pool, rebooted -> no problem
I then applied the latest updates (10.9.5?), rebooted -> no problem

Didn't have time to push things harder than that but it seems superficially ok.

Do you have any further details you can add?

I assume "not booting" really translates to panicking on or shortly after boot, can you check for kernel panics and provide please?

Posts: 286
Joined: Thu Mar 06, 2014 12:51 pm

Re: v1.6.1 issues on Mavericks

Postby nodarkthings » Wed Mar 15, 2017 4:20 pm

No KP, just stops at the rotating "/" (you know what? I'm still using Chimera/Chameleon, not Clover)
That's why I first thought it could be a BIOS thing... then a drive going south... I first tried disabling virtualization, checked SMART status, and every BIOS setting I could think of being related...
=> The only thing that allowed booting was disconnecting the offending drive.
Maybe it's the update that went bad, I should try thoroughly uninstalling 1.5.2 and do a clean reinstall of 1.6.1?
I confirm that with 1.5.2, all is right, I've recreated all the pools that gave problems with 1.6.1 (same HFS partitions, same names) and all is well... I believe I'm cursed! ;)
Posts: 150
Joined: Mon Jan 26, 2015 10:32 am

Re: v1.6.1 issues on Mavericks

Postby nodarkthings » Wed Mar 15, 2017 4:34 pm

Well, after all it could be a Chimera issue related to partitioning, people seem to have had more or less similar issues there: https://www.tonymacx86.com/threads/chimera-text-spinner-suddenly-hangs-at-about-or-with-presence-of-internal-time-machine-dri.97781/
But is there something slightly different in the way 1.6.1 creates pools, compared to 1.5.2?
Otherwise I don't understand what could make the difference. :?
Posts: 150
Joined: Mon Jan 26, 2015 10:32 am

Re: v1.6.1 issues on Mavericks

Postby nodarkthings » Thu Mar 16, 2017 5:51 am

Just in case, I've updated Chameleon to the latest available (Enoch-rev.2848), reinstalled ZFS 1.6.1 after thoroughly cleaning v1.5.2.
I've got the same result as my ultimate trial: the pool doesn't mount after reboot (I see a brief notification saying it's exported), but the underlying HFS partition mounts instead.
Then, if I do sudo zpool import: no pools available to import
So not being able to create a new pool, the computer boots... :mrgreen:
Here are some extracts of what I see in the Console.
After the pool creation:
Code: Select all
zed[1072]: eid=15 class=config.sync pool=Test
sudo[1074]:     root : TTY=unknown ; PWD=/ ; USER=Bdha ; COMMAND=/usr/bin/osascript -e display notification "zpool.cache file has been renamed" with title "config.sync"
kernel[0]: zfs_vfs_mount: fspec 'Test' : mflag 0100 : optptr 0x7fff5a50cfe0 : optlen 4096 : options
mds[38]: (Normal) Volume: volume:0x7fabe8874e00 ********** Bootstrapped Creating a default store:3 SpotLoc:/Volumes/Test/.Spotlight-V100 SpotVerLoc:/Volumes/Test/.Spotlight-V100/Store-V1 occlude:0 /Volumes/Test
fseventsd[49]: could not open <</Volumes/Test/.fseventsd/fseventsd-uuid>> (No such file or directory)
fseventsd[49]: log dir: /Volumes/Test/.fseventsd getting new uuid: FF886513-2EC1-4ADF-A8E0-6220BE0D2815

And after reboot:
Code: Select all
zed[513]: Pool export Test

kernel[0]: hfs: mounted Untitled on device disk1s7
kernel[0]: hfs: BlockMarkFreeInternal() trying to free unallocated blocks on volume Untitled
kernel[0]: hfs: Runtime corruption detected on Untitled, fsck will be forced on next mount.

The last two lines being repeated many times.

Just to avoid any doubt, here is the command I use for creating pools:
Code: Select all
sudo zpool create -f -o ashift=12 -O compression=lz4 -O casesensitivity=insensitive -O atime=off -O normalization=formD Test /dev/disk1s7
Posts: 150
Joined: Mon Jan 26, 2015 10:32 am

Re: v1.6.1 issues on Mavericks

Postby nodarkthings » Fri Mar 17, 2017 1:55 am

Apparently... SOLVED! (EDIT: BUT NO!!! So consider what follows as a step in my trials)

How I hate this type of issues when in the end you don't know neither what actually fixed it nor what was causing it... :cry:
I swear I tried many times before starting this thread, and all was cured every time when I was coming back to v1.5.2!
I suppose it involved a combination of factors, probably including a small difference between the two versions.
After my last post (those trials were on my HD), I checked the HD with Disk Utility and there was a problem with the drive's structure that got fixed, now I could create pools again.

But this doesn't explain why my SSD refused booting even on its own when a 1.6.1 pool was on it... :shock:
(which was the initial issue)
I haven't updated Chimera/Chameleon on it and there was no structure problem warning by Disk Utility...

Anyway, I now have repeated exactly the same things as before on both disks and all seems ok, after a few pools creations and reboots!
Last edited by nodarkthings on Wed May 03, 2017 4:37 am, edited 1 time in total.
Posts: 150
Joined: Mon Jan 26, 2015 10:32 am

Re: v1.6.1 issues on Mavericks

Postby nodarkthings » Sun Mar 19, 2017 10:00 am


Same player shoots again...
Creating the first pools (one on each drive) went ok but when I destroyed the pools on my HD and created new ones, I had the exact same behavior as before (unable to boot when drive attached, then when hot-plugged: pools not mounting and HFS partitions mounting instead — and sudo zpool import saying "no pools available to import").

But this time, no structure problem warning in Disk Utility, I rebuilt the partition map, anyway just in case but no change.
I reinstalled latest Chameleon (Enoch). No change.
Then I reinstalled 1.5.2 but nothing was solved before I destroyed the offending partitions from the HD.
Recreated the same partitions once again, same pools, same names.
Now it works ok... with 1.5.2.
Posts: 150
Joined: Mon Jan 26, 2015 10:32 am

Return to Hackintoshes

Who is online

Users browsing this forum: No registered users and 2 guests