Page 3 of 5

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 7:16 am
by nodarkthings
- I installed RC5 upon 1.3.0 (not uninstalling it before, was I right?). Installation went ok
- rebooted
- Terminal "sudo zpool import" hangs.
Here's the new spindump.
spindump.txt.zip
(96.02 KiB) Downloaded 371 times

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 7:24 am
by ilovezfs
Yeah installing on top of 1.3.0 is fine - the installer will run its own uninstaller first anyway.

What devices are connected?

Also, can you upload /var/log/system.log?

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 7:55 am
by nodarkthings
No other device connected except for an old Kensington Expert Mouse.
(I mean nothing powered on, there's actually a usb drive, a usb drive dock and a usb dvd burner, but all with their power cords detached)
Here's the system rebooting in a brand new admin user, just after running "sudo zpool import".
system.log
(51.85 KiB) Downloaded 446 times

Now I'll try the same detatching anything but the kb and mouse. ;)

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 8:11 am
by nodarkthings
same result with everything detached including the trackball. :|

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 8:14 am
by nodarkthings
And to be totally exhaustive, my internal drives are a SSD (OS), a 1Tb and a 160Gb (the one with the test pool)

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 8:19 am
by ilovezfs
OK so there's still a pool in sight. Then let's see if

Code: Select all
mkdir ~/empty
sudo zpool import -d ~/empty

hangs or not.

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 9:24 am
by nodarkthings
No, it doesn't hang!

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 9:39 am
by ilovezfs
sudo zdb -e -p /dev Videos

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 9:41 am
by nodarkthings
Hangs!

Re: ZFS dead on a 10.9 partition, not on another...

PostPosted: Tue Jan 27, 2015 9:42 am
by ilovezfs
spindump