ZFS dead on a 10.9 partition, not on another...

We won't tell.

Re: ZFS dead on a 10.9 partition, not on another...

Postby nodarkthings » Tue Jan 27, 2015 3:51 am

... and after a while, the disk goes to sleep (be it mounted in SATA or in an external USB dock).
nodarkthings
 
Posts: 75
Joined: Mon Jan 26, 2015 10:32 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby ilovezfs » Tue Jan 27, 2015 3:55 am

Are you running the commands as root?
ilovezfs
 
Posts: 229
Joined: Thu Mar 06, 2014 7:58 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby nodarkthings » Tue Jan 27, 2015 4:48 am

Yes, I forgot to mention that: I'm doing everything either logged in as the Root user or using sudo.
nodarkthings
 
Posts: 75
Joined: Mon Jan 26, 2015 10:32 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby nodarkthings » Tue Jan 27, 2015 4:53 am

... and in /etc/zfs/ there's no zpool.cache, just the zed.d folder.
nodarkthings
 
Posts: 75
Joined: Mon Jan 26, 2015 10:32 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby ilovezfs » Tue Jan 27, 2015 4:59 am

OK, so one thing to bear in mind is that once it's cooked, it's cooked - meaning if any of the commands deadlock or hang, you will need to reboot to get back into a functional state. So if sudo zpool import tank hangs, a sudo zpool import in another window will hang, too. After a reboot, sudo zpool import might run fine if you haven't run sudo zpool import tank yet.

So from a clean boot, does sudo zpool import hang?
ilovezfs
 
Posts: 229
Joined: Thu Mar 06, 2014 7:58 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby nodarkthings » Tue Jan 27, 2015 5:19 am

Here I am, clean rebooted in an admin account (not the Root user), directly doing "sudo zpool import" (note that my pool drive is currently in the SATA bay) and...
Nothing.
I've checked the Console:
27/01/2015 14:07:53,313 sudo[721]: Bdha : TTY=ttys000 ; PWD=/Users/Bdha ; USER=root ; COMMAND=/usr/sbin/zpool import
27/01/2015 14:08:13,105 xpcd[275]: Info.plist does not contain an XPCService dictionary: /System/Library/Frameworks/Security.framework/XPCServices/SecurityAgent.xpc

I don't know if the xpcd line has something to do with it, just in case...
Now, the disk went to sleep and import is still hanged.
nodarkthings
 
Posts: 75
Joined: Mon Jan 26, 2015 10:32 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby ilovezfs » Tue Jan 27, 2015 6:06 am

While it's hung please run sudo spindump
ilovezfs
 
Posts: 229
Joined: Thu Mar 06, 2014 7:58 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby nodarkthings » Tue Jan 27, 2015 6:18 am

I rebooted, re "sudo zpool import" after quitting anything else and here is the spindump result.
Hmmm... another limitation from the site: "The file is too big, maximum allowed size is 256 KiB" ;)
Last edited by nodarkthings on Tue Jan 27, 2015 6:30 am, edited 1 time in total.
nodarkthings
 
Posts: 75
Joined: Mon Jan 26, 2015 10:32 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby nodarkthings » Tue Jan 27, 2015 6:21 am

spindump.txt.zip
(94.08 KiB) Downloaded 270 times
Here it is compressed!
nodarkthings
 
Posts: 75
Joined: Mon Jan 26, 2015 10:32 am

Re: ZFS dead on a 10.9 partition, not on another...

Postby ilovezfs » Tue Jan 27, 2015 7:03 am

Now please upgrade to rc5 and repeat the procedure.
ilovezfs
 
Posts: 229
Joined: Thu Mar 06, 2014 7:58 am

PreviousNext

Return to Hackintoshes

Who is online

Users browsing this forum: No registered users and 1 guest

cron