Zpool not showing in Finder

We won't tell.

Zpool not showing in Finder

Postby zfsuser » Sun Jan 25, 2015 5:09 pm

Hello.

My 6 x 3TB zpool in Raidz2 is no longer showing in finder.

Other single disk pools are still showing fine.

This is a newly built socket 2011 4 core hackintosh with 32 GB RAM. (GA-X79-UD3) (Clover)

(The pool consists of 6 identical Seagate 3TB 7.2 drives plus a 5GB ZIL partition sharing the system SSD (PCI) plus one more dedicated 128 GB SSD for L2ARC) (OpenZFS on OS X Version 1.3.0)

CORRECTION: both ZIL and L2ARC are separate ZFS partitions sharing the 128 GB system SSD (PCI).

The dedicated 128GB SSD is used as a back-up for the system partition using Carbon Copy Cloner.

All HDDs are connected to the on-board SATA headers.

Never had a ZFS problem before on other hacks.

The zfspool (tank) is on-line according to zpool status in terminal.

The machine booted up and shut down fine over the past week while I was transferring data on to the pool, (so far 5TB of data of ca. 12 TB avail).

Since last night I can no longer get the tank to be avail in finder.

Any help is much appreciated.

Many thanks in advance

ZU
Last edited by zfsuser on Sun Jan 25, 2015 8:20 pm, edited 3 times in total.
zfsuser
 
Posts: 6
Joined: Sun Jan 25, 2015 4:55 pm

Re: Zpool not showing in Finder

Postby lundman » Sun Jan 25, 2015 7:21 pm

Need output of

diskutil list

zpool import

zpool status

zpool import tank
User avatar
lundman
 
Posts: 402
Joined: Thu Mar 06, 2014 2:05 pm
Location: Tokyo, Japan

Re: Zpool not showing in Finder

Postby AlexWasserman » Sun Jan 25, 2015 7:37 pm

I would add:

mount
zfs mount
AlexWasserman
 
Posts: 11
Joined: Sat Mar 29, 2014 3:40 pm

Re: Zpool not showing in Finder

Postby zfsuser » Sun Jan 25, 2015 9:38 pm

Thank you both, Alex and lundman.

outputs :

diskutil list:

http://fpaste.org/174687/22498891/

zpool import:

bash-3.2# zpool import
bash-3.2#

zpool status:

http://fpaste.org/174688/22249996/

zpool import tank:

bash-3.2# zpool import tank
cannot import 'tank': a pool with that name is already created/imported,
and no additional pools with that name were found
bash-3.2#

mount:

bash-3.2# mount
/dev/disk0s2 on / (hfs, local, journaled)
devfs on /dev (devfs, local, nobrowse)
/dev/disk1s2 on /Volumes/OsX Back-up (hfs, local, journaled)
map -hosts on /net (autofs, nosuid, automounted, nobrowse)
map auto_home on /home (autofs, automounted, no browse)


zfs mount:

bash-3.2# zfs mount
bash-3.2#

and finally:

bash-3.2# zpool import tank
cannot import 'tank': a pool with that name is already created/imported,
and no additional pools with that name were found
bash-3.2# zpool import tank Raidz2tank
cannot import 'tank': a pool with that name is already created/imported,
and no additional pools with that name were found
bash-3.2# zpool export tank
bash-3.2# zpool import tank Raidz2tank <- brings the pool back in finder
bash-3.2# zpool export Raidz2tank
Running process: '/usr/sbin/diskutil' 'unmount' '/Raidz2tank'
Unmount successful for /Raidz2tank
bash-3.2# zpool import Raidz2tank tank
cannot mount '/tank': directory is not empty
bash-3.2#
Last edited by zfsuser on Sun Jan 25, 2015 9:47 pm, edited 2 times in total.
zfsuser
 
Posts: 6
Joined: Sun Jan 25, 2015 4:55 pm

Re: Zpool not showing in Finder

Postby ilovezfs » Sun Jan 25, 2015 9:40 pm

zfs get all
ilovezfs
 
Posts: 229
Joined: Thu Mar 06, 2014 7:58 am

Re: Zpool not showing in Finder

Postby zfsuser » Sun Jan 25, 2015 9:48 pm

thank you.

zfs get all

http://ur1.ca/jjjcp
zfsuser
 
Posts: 6
Joined: Sun Jan 25, 2015 4:55 pm

Re: Zpool not showing in Finder

Postby ilovezfs » Sun Jan 25, 2015 9:51 pm

OK. So what happens if you
Code: Select all
zfs mount tank
ilovezfs
 
Posts: 229
Joined: Thu Mar 06, 2014 7:58 am

Re: Zpool not showing in Finder

Postby zfsuser » Sun Jan 25, 2015 9:57 pm

zfs mount tank

bash-3.2# zfs mount tank

and the pool "tank" is back

It never occurred to me to mount the pool as it always just there after each reboot.

Did smth break do you think?

Thanks a lot!
zfsuser
 
Posts: 6
Joined: Sun Jan 25, 2015 4:55 pm

Re: Zpool not showing in Finder

Postby ilovezfs » Sun Jan 25, 2015 10:01 pm

Well it should mount all datasets during import unless you import -N.

zpool export tank
zpool import tank

And it should be mounted.
ilovezfs
 
Posts: 229
Joined: Thu Mar 06, 2014 7:58 am

Re: Zpool not showing in Finder

Postby zfsuser » Sun Jan 25, 2015 10:09 pm

thank you.

hmm ...

not working, here's my terminal output:

ABC-Home:~ admin$ zpool export tank
ABC-Home:~ admin$ zpool import tank
cannot import 'tank': no such pool available
ABC-Home:~ admin$ sudo -s
Password:
bash-3.2# zpool export tank
cannot open 'tank': no such pool
bash-3.2# zpool import
pool: tank
id: 15838324441756794708
state: ONLINE
action: The pool can be imported using its name or numeric identifier.
config:

tank ONLINE
raidz2-0 ONLINE
disk2 ONLINE
disk4 ONLINE
disk6 ONLINE
disk3 ONLINE
disk5 ONLINE
disk7 ONLINE
cache
disk0s4
logs
disk0s5 ONLINE
bash-3.2# zpool import tank
cannot mount '/tank': directory is not empty
bash-3.2# zfs mount tank <-brings back the pool in finder
bash-3.2# zpool export tank
Running process: '/usr/sbin/diskutil' 'unmount' '/tank'
Unmount successful for /tank
bash-3.2# zpool import tank
cannot mount '/tank': directory is not empty
bash-3.2# zfs mount tank <-brings back the pool in finder
bash-3.2# zpool export tank
Running process: '/usr/sbin/diskutil' 'unmount' '/tank'
Unmount successful for /tank
bash-3.2# zpool import tank
cannot mount '/tank': directory is not empty
bash-3.2#
zfsuser
 
Posts: 6
Joined: Sun Jan 25, 2015 4:55 pm

Next

Return to Hackintoshes

Who is online

Users browsing this forum: No registered users and 1 guest