No love for Yosemite

We won't tell.

No love for Yosemite

Postby orckland » Mon Jan 05, 2015 3:12 pm

Greetings, OpenZFS on OS X fans and braintrust!

I completed a fresh install on my LGA2011 hack (Asus P9X79Pro) over the break and have had nothing but problems re: ZFS since. I have three HP RocketRaid cards (2x 2722 and one 2720SGL) in JBOD, with two connected to (two) separate ZFS pools that have been working reliably (albeit slowly) under Mavericks. The second 2722 card just connects to drives formatted as NTFS volumes without ZFS. All cards were working fine and have the latest bios 1.5. This setup has been very reliable for two years and has max mem, all quality components, and latest Asus bios.

Now, however, I am unable to get the primary pool to remount after 1-2 reboots under Yosemite. I have moved the cards several times and am currently using only the internal 2720 with 8 drives in a local RAID-Z2. The second pool is a special setup that I migrated, but have not yet upgraded from Zevo, so I have not tried it yet under Yos. After resetting the bios and even removing the battery, resetting all the the BIOS options, and booting into a fresh Yosemite install using the latest Clover and RampageDev's guide, I can mount and use the primary Zpool for the first one or two sessions. If I reboot, I can mount it again and use it, but on the next reboot, the drive activity LEDs show constant access, and the pool will not import or mount again. I have tried manually unmounting and exporting the zpool after the first or second boot, but the same behaviour occurs. FYI, in the console, there will be numerous hardware connection timeouts [kernel[0]: Task timeout reset bus] at the second reboot when all the drive lights stay on after an attempt to manually mount or import (the terminal process hangs). Diskutil list shows all the ZFS drives and partitions. This local zpool was created using an earlier dev build of O3X and would mount automatically under Mav; in Yos I have to import for some odd reason. If I reset, the machine will lock up during the boot process: either the ZFS drives will not show in the Highpoint bios screen and will freeze there, or, after the mobo splash screen, it will hang at a blinking cursor, before ever getting to the HP bios screen. At that point, I am forced to reset the bios and/or remove the battery. FYI, all the LEDs are full on during hardware reset until bios is cleared. Without the HP cards and ZFS, I do not experience these issues.

I do have the common suhelperd error (I now kill the process immediately after reboot) as well as a few other oddball errors in the console.

FYI, I started with the general release v. 1.3 and have tried RC3 and 4, as well as the signed 20141127 dev build. I am currently back to using release 1.3.

Any ideas? I am fresh out, and do not want to go back to Mav. I have considered that the mobo may be erratic and do have a spare, but would like to avoid transplantation and experimentation until I am mostly sure. I have no issues running Windows on this machine, and Asus mobs are generally bullet-proof nowadays.

edit: added error message "Task timeout reset bus"
Last edited by orckland on Mon Jan 05, 2015 4:26 pm, edited 1 time in total.
Posts: 10
Joined: Thu Jun 19, 2014 9:29 am

Re: No love for Yosemite

Postby orckland » Mon Jan 05, 2015 4:23 pm

The most prolific oddball error I am seeing in the console is:

CoreServicesUIAgent[31375]: error -5000 while setting quarantine data

I have almost 20,000 entries for this within a 6-minute time span after rebooting and importing the pool, and then it finally stopped.
Posts: 10
Joined: Thu Jun 19, 2014 9:29 am

Re: No love for Yosemite

Postby Brendon » Tue Jan 06, 2015 12:03 am

Not a very useful reply but we know that we run fine on 10.10.1.

- Brendon.
Posts: 286
Joined: Thu Mar 06, 2014 12:51 pm

Return to Hackintoshes

Who is online

Users browsing this forum: No registered users and 1 guest